Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > Electronics
Register Forgot Password?

Electronics Need help wiring something up? Thinking of adding an electrical component to your car? Need help troubleshooting that wiring glitch?

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 12-14-2010, 07:36 PM   #1
Member
 
Join Date: Oct 2008
Location: Lowell Mass
Posts: 249
Car: 1990 Camaro RS
Engine: 305 TBI
Transmission: 5 spd

Classifieds Rating: (0)
How Do i fix my high beams. They do not turn on

when i try to turn on my high beams they do not come on. What can i do. I pull back the turning signal lever and nothing. they dont engage. Im stuck?
carralo1 is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 07:59 AM   #2
Member
 
Brads RS's Avatar
 
Join Date: Feb 2001
Location: Ellis Grove, IL.
Posts: 175
Car: 1992 Camaro RS
Engine: Custom build 355 TPI
Transmission: 700R4
Axle/Gears: 3.23

Classifieds Rating: (0)

Re: How Do i fix my high beams. They do not turn on

Have you checked the dimmer switch to make sure its working correctly? Could be bad, or out of adjustment. Its located on the lower steering column near the ignition power switch.
Brads RS is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 08:59 AM   #3
Member
 
Join Date: Jul 2008
Location: Fox Lake, Illinois
Posts: 195
Car: 1991 RS
Engine: 350 TBI
Transmission: 700r4
Axle/Gears: 3.08 lt. slip

Classifieds Rating: (1)
Re: How Do i fix my high beams. They do not turn on

This may sound stupid but also check to be sure both of your high beams are not burned out.
Jono4820 is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 09:54 AM   #4
Senior Member
 
88FormulaKiller's Avatar
 
Join Date: Mar 2008
Location: NH
Posts: 636
Car: 1967 Firebird P.T.
Engine: 427 LS3
Transmission: MN12 6 speed
Axle/Gears: 3.23 10 Bolt

Classifieds Rating: (8)
Re: How Do i fix my high beams. They do not turn on

i have the same problem with my 91 cherokee and 91 firebird, when you pull the lever back it doesnt even click, its the catch lever inside the column that attaches to the high beam/wiper lever. i havent taken one of them apart yet to see how it is repaired.
88FormulaKiller is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 10:34 AM   #5
Member
 
Join Date: Oct 2008
Location: Lowell Mass
Posts: 249
Car: 1990 Camaro RS
Engine: 305 TBI
Transmission: 5 spd

Classifieds Rating: (0)
Re: How Do i fix my high beams. They do not turn on

Quote:
Originally Posted by 88FormulaKiller View Post
i have the same problem with my 91 cherokee and 91 firebird, when you pull the lever back it doesnt even click, its the catch lever inside the column that attaches to the high beam/wiper lever. i havent taken one of them apart yet to see how it is repaired.
yes exactly. thats my prblem it doesnt click. i have a parts car that when i pull it back it clicks. how can i remove it and put it on this car?
carralo1 is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 12:18 PM   #6
Member
 
Join Date: Oct 2008
Location: Lowell Mass
Posts: 249
Car: 1990 Camaro RS
Engine: 305 TBI
Transmission: 5 spd

Classifieds Rating: (0)
Re: How Do i fix my high beams. They do not turn on

how do i remove the turn signal assembly from the steering column. ive removed the steering wheel, had to go to auto zone and rent a steering wheel puller. now i just needa remove the turn signal assembly...
carralo1 is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 12:22 PM   #7
Senior Member
 
88FormulaKiller's Avatar
 
Join Date: Mar 2008
Location: NH
Posts: 636
Car: 1967 Firebird P.T.
Engine: 427 LS3
Transmission: MN12 6 speed
Axle/Gears: 3.23 10 Bolt

Classifieds Rating: (8)
Re: How Do i fix my high beams. They do not turn on

i dont have answer for you but i will say that i looked at my 91 cherokee lever and it looks very very similar to the set-up on my 91 firebird and from i could see at a glance it may be able to be rigged up with a rod (kind of like a lock rod inside the door if it was cut and bent) and made to work that way temporarily. i can actually push the lever inside the column forward and turn my high beams on since the cover/trim piece is off, may be able to do the same with a firebird/camaro column to get you by... just my .02.
88FormulaKiller is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 12:25 PM   #8
Member
 
Brads RS's Avatar
 
Join Date: Feb 2001
Location: Ellis Grove, IL.
Posts: 175
Car: 1992 Camaro RS
Engine: Custom build 355 TPI
Transmission: 700R4
Axle/Gears: 3.23

Classifieds Rating: (0)

Re: How Do i fix my high beams. They do not turn on

Normally there are 2 screws holding the turn signal assembly in and one that holds the turn lever, remove them then unplug the connector at the bottom of the column and pull the turn sig assembly up and out of the way, next i think there are two or three bolts/screws that hold the lock cylinder housing down, you will need to loosen these then pull it up a little. Next there is a cover over the turn sig lever that should be free now for you to work on. Hope this helps. I think thats what you will have to do, its been a while since i have been there.
Brads RS is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 06:08 PM   #9
Supreme Member
 
Join Date: Aug 2009
Location: Central California
Posts: 1,076
Car: 92 Camaro RS
Engine: LO3
Transmission: T5
Axle/Gears: stock

Classifieds Rating: (97)
Re: How Do i fix my high beams. They do not turn on

If pulling back the lever doesn't make a click, then it's probably just the switch down the steering column that needs to be tightened up in the right position to make it work. Get under there and watch the rod move when you pull back the lever. See that whitish plastic switch the rod is going into? push in on that. If it clicks and your brights are now working, just loosen the two screws that hold the switch on a little bit, pull the switch forward and retighten until you've got it working right. Adjust it with the steering wheel in the position it's in when you drive it. Much easier than that other thing
henryd3 is offline vBGarage Page   Reply With Quote
Old 12-15-2010, 06:08 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > Electronics

Tags
1991, 2001, 89, beam, beams, burned, camaro, car, firebird, fix, high, highbeams, reassemble, signal, switch, turn, working
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 04:11 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details