Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > TBI
Register Forgot Password?

TBI Throttle Body Injection discussion and questions. L03/CFI tech and other performance enhancements.

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 02-21-2011, 02:14 PM   #1
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
1990 camaro 305 tbi injectors wont open

pls help!i have spent 1.5 million dollars on this car tryin to get it to run replaced everything from the chip key to the pickupcoil to the computer still no luck any help would be gratefully appreciated
slider07 is offline vBGarage Page   Reply With Quote
Old 02-21-2011, 03:51 PM   #2
Supreme Member
 
Join Date: Sep 2002
Location: Cary, North Carolina
Posts: 9,192
Car: 1992 RS
Engine: Carbed 350
Transmission: 700R4
Axle/Gears: 3.42 posi

Classifieds Rating: (0)

Send a message via AIM to camaronewbie
Re: 1990 camaro 305 tbi injectors wont open

So what exactly is the problem - we need details.

Will the car run if you put a small amount of gas in the TBI unit?
Do the injectors spray while it's running off that?
Does the fuel pump prime when you turn on the key?
When was the last time fuel filter was replaced?
Does the SECURITY light come on and/or flash when you are trying to start the car?

Your key has a pellet in it - you mentioned replacing a key chip - what exactly are you talking about? (details here)
- Did you get a new key?
- Was the new key same pellet as the old key?
- Did you try the VATS bypass method?

You mention a new computer - What year ECM did you replace with?

We need year of car, engine size, any mods you've done, what tranny, etc.
__________________
1992 25th Anniversary RS T-Top
350 Carb 10:1 Dometops Mild Cam
Hedmann Headers Hi-Flo Cat/Aerochamber Muffler
700R4 B&M Shift Kit LS1 Disc Rear w/3.42 Posi
Poly Bushings Eibach Prokit Bilstein Shocks/Struts
HOK Candy Teal on Silver Flake IROC Hood
camaronewbie is offline vBGarage Page   Reply With Quote
Old 02-22-2011, 10:02 AM   #3
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

yeah had a new security key made its a 1990 camaro 305 v8 with a 700 r4 no mods all stock new fuel pump new computer new pickup coil i have replaced so many things its insane new module im at my wits end pump primes plenty of pressure injectors will open if wired hot just wont open on their own

Last edited by slider07; 02-22-2011 at 10:07 AM. Reason: forgot info
slider07 is offline vBGarage Page   Reply With Quote
Old 02-27-2011, 05:51 PM   #4
Junior Member
 
Join Date: Feb 2011
Location: Northern Baltimore County, MD
Posts: 12
Car: 91 T-Top RS
Engine: 305 TBI
Transmission: 700R4
Axle/Gears: To be determined at the JY.

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

You should definitely consider answering all the questions there. Did you match the part numbers on the ECM, first of all? Second, Did you check the ground wires on the injectors? One wire is always hot (meaning if you get your multimeter set one 20v DC scale (40 if you have a nice one, but I doubt it, those are for people who do this for a living and can afford crap like that) with the red lead in the terminal on the pigtail, and the black one on the negative battery post, it should read 12.0-12.6 or so. If it's under 12.0, check your battery, if the battery read well and the injector wire doesn't, look for a bad wire. If the battery reads under 12.0, charge the battery or get a new one. If the problem isn't the battery, look for a faulty wire going to the ECM, or a bad ground past it. Most likely, you're going to find that you have a bad wire to the ECM by this point, but it's also possible your ECM isn't grounded properly.

Oh, and one more thing, with the DVOM set to the 200 or 400 ohms resistance scale (the thing that looks like the greek letter omega) check resistance across the two prongs on the injectors. They should both read between 1.16-1.36 ohms on an L03 TBI unit. If they're out of range, replace them.

One other thing, do you have a noid light?
Catalina is offline vBGarage Page   Reply With Quote
Old 02-27-2011, 07:39 PM   #5
Supreme Member
 
Join Date: Sep 2002
Location: Cary, North Carolina
Posts: 9,192
Car: 1992 RS
Engine: Carbed 350
Transmission: 700R4
Axle/Gears: 3.42 posi

Classifieds Rating: (0)

Send a message via AIM to camaronewbie
Re: 1990 camaro 305 tbi injectors wont open

Getting a new key won't help if the VATS module itself is the issue. VATS module sends a pulsed wave signal to the ECM telling it to run the injectors - ECM doesn't get that signal, it won't fire the injectors.

AND - if you replaced the ECM with one from a different year car, it's possible that YOUR VATS module is sending a different pulse wave frequency than what the ECM is expecting to receive (there are two frequencies I believe, 30Hz and 50Hz).

I'd go back to the original ECM, and try the new key. If that doesn't work, then I'd leave the original ECM (unless there was some other issue with it), and buy a VATS Module bypass box, available on ebay, from Painless, etc. These bypass boxes take the VATS module out of the equation, by sending either of the two frequencies that the ECM is looking for.
__________________
1992 25th Anniversary RS T-Top
350 Carb 10:1 Dometops Mild Cam
Hedmann Headers Hi-Flo Cat/Aerochamber Muffler
700R4 B&M Shift Kit LS1 Disc Rear w/3.42 Posi
Poly Bushings Eibach Prokit Bilstein Shocks/Struts
HOK Candy Teal on Silver Flake IROC Hood
camaronewbie is offline vBGarage Page   Reply With Quote
Old 02-27-2011, 07:44 PM   #6
Junior Member
 
Join Date: Feb 2011
Location: Northern Baltimore County, MD
Posts: 12
Car: 91 T-Top RS
Engine: 305 TBI
Transmission: 700R4
Axle/Gears: To be determined at the JY.

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

I think we're assuming too much here... Does the car crank or not? You're not being very clear on this issue. Please elaborate if you still need help, because as much as we try, we can only take shots in the dark. If it's cranking, your VATS is fine, if not, it may or may not be the problem. Please respond with details, or I will personally consider this thread dead, as I expect the others likely will as well.

Thanks,
Catalina
Catalina is offline vBGarage Page   Reply With Quote
Old 02-27-2011, 08:03 PM   #7
Supreme Member
 
Join Date: Sep 2002
Location: Cary, North Carolina
Posts: 9,192
Car: 1992 RS
Engine: Carbed 350
Transmission: 700R4
Axle/Gears: 3.42 posi

Classifieds Rating: (0)

Send a message via AIM to camaronewbie
Re: 1990 camaro 305 tbi injectors wont open

Quote:
Originally Posted by Catalina View Post
If it's cranking, your VATS is fine, ....
NOT TRUE. If it cranks, that just means the VATS is grounding the starter enable relay (or, someone has wired in a ground for the starter enable relay). The VATS could still be messed up by not sending the pulse wave to the ECM, or by sending the wrong pulse wave to this swapped in ECM.

There are plenty of occurrences where folks got the starter to turn, but VATS still kept injectors from firing.
camaronewbie is offline vBGarage Page   Reply With Quote
Old 02-27-2011, 08:11 PM   #8
Junior Member
 
Join Date: Feb 2011
Location: Northern Baltimore County, MD
Posts: 12
Car: 91 T-Top RS
Engine: 305 TBI
Transmission: 700R4
Axle/Gears: To be determined at the JY.

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

You're right, I didn't notice that none of the wiring diagrams I have here have the whole VATS module in one diagram. It's pretty stupid that it's like that, but looking more closely at the diagrams I've got, that's true. That could be a pain to diagnose for a parts replacer, though...

EDIT:
In light of this knowledge, I'm going to go ahead and kill my VATS while I don't depend on this car. My ignition lock cylinder is going up anyway and those keys are expensive...
/EDIT
Catalina is offline vBGarage Page   Reply With Quote
Old 02-28-2011, 07:27 AM   #9
Moderator
 
Join Date: Mar 2002
Location: Chasing Electrons
Posts: 14,470
Car: check
Engine: check
Transmission: check

Classifieds Rating: (1)

Re: 1990 camaro 305 tbi injectors wont open

If you think that the ECM isn't getting the VATs signal, pull the PROM out and try starting it. If it starts and runs you found the problem. NOTE: be sure to leave the small CALPAK in the ECM.

RBob.
__________________

www.DynamicEFI.com

'92 Camaro in Dark Green Gray Metallic
RBob is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 12:39 PM   #10
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

ok im trying my best to do it all the car will run if you put gas in tbi the computer is brand new from advance everything seems to be working except the injectors the guy who made the key scanned for vats code retrieved it showing to be number 5 of possible 15 light is working correctly im thinkin its the prom chip need to know if other vehicle proms will work?
slider07 is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 01:38 PM   #11
Supreme Member
 
Join Date: Sep 2002
Location: Cary, North Carolina
Posts: 9,192
Car: 1992 RS
Engine: Carbed 350
Transmission: 700R4
Axle/Gears: 3.42 posi

Classifieds Rating: (0)

Send a message via AIM to camaronewbie
Re: 1990 camaro 305 tbi injectors wont open

Go ahead and replace the prom again, you're obviously dying to anyway. Then when that doesn't work, we go back to square one, which is where we are now but you won't answer the questions so we can help you.

Your initial post sums it all up quite well ... you've spent 1.5million dollars throwing parts at this car without troubleshooting the REAL problem. So why do you insist on continuing down that same path? It's getting you nowhere. A car is NOT a woman - throwing cash at it won't make it run!

There's a gazillion different reasons the injectors won't fire. With 99% of problems people want to replace ECM's just like you, and 99% of the time there's nothing wrong with the ECM - they jump to the same bad conclusion you have. There's nothing magical about a ECM - it just takes the data it's given, compares it to stored data charts, and then changes fuel tables and timing advance/retard signals to accomodate. It's not some Master Brain that magically sends out little workers to fix mechanical or electrical issues.

You should have figured this out by now, since you've already changed ECM once and car still doesn't work. I've been on this board 5+ years now, I've read at least 1000 people that changed there ECM - maybe 3 of them actually needed to. The ECM's are about the last thing that ever "goes bad".

Do you want to fix the car, or do you want to keep throwing ash at it. You don't need us for the latter. For the former, let's go back to basics and work through the REAL problem of why the injectors won't fire. I'll ask again...

1) Does the fuel pump prime?
2) Has fuel filter been changed in last 30 days?
3) Does the security light come on or flash when trying to start car?
__________________
1992 25th Anniversary RS T-Top
350 Carb 10:1 Dometops Mild Cam
Hedmann Headers Hi-Flo Cat/Aerochamber Muffler
700R4 B&M Shift Kit LS1 Disc Rear w/3.42 Posi
Poly Bushings Eibach Prokit Bilstein Shocks/Struts
HOK Candy Teal on Silver Flake IROC Hood
camaronewbie is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 01:57 PM   #12
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

had a high quality locksmith do it the ecm is new prom is not will run when u put fuel in tbi
slider07 is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 01:59 PM   #13
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

yes ive done all that everything checks out except the inj pulse i do have a nice ohm meter two of them actually both fluke
slider07 is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 02:01 PM   #14
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

yes it is the correct key i got the computer from advance so im sure its right fuel pump working good filter is new
slider07 is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 02:04 PM   #15
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

security light comes on then goes off as it should pump is good filter is good
slider07 is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 02:08 PM   #16
Supreme Member
 
Join Date: Sep 2002
Location: Cary, North Carolina
Posts: 9,192
Car: 1992 RS
Engine: Carbed 350
Transmission: 700R4
Axle/Gears: 3.42 posi

Classifieds Rating: (0)

Send a message via AIM to camaronewbie
Re: 1990 camaro 305 tbi injectors wont open

Then I'd say you should try one of the VATS bypass modules from ebay or Painless or something - they run about $20 - $50. It gets wired into the ECM to give it the right signal to tell the ECM to turn on the injectors. There's 2 signals that I'm aware of, a 30Hz signal and a 50Hz signal - just make sure you order one that does either. I'm guessing that either 1) your VATS module is not sending the right (or any) signal to the ECM, or 2) the replacement ECM you got isn't getting the signal correctly (not correct ECM or something).
__________________
1992 25th Anniversary RS T-Top
350 Carb 10:1 Dometops Mild Cam
Hedmann Headers Hi-Flo Cat/Aerochamber Muffler
700R4 B&M Shift Kit LS1 Disc Rear w/3.42 Posi
Poly Bushings Eibach Prokit Bilstein Shocks/Struts
HOK Candy Teal on Silver Flake IROC Hood
camaronewbie is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 02:09 PM   #17
Junior Member
 
Join Date: Feb 2011
Posts: 8

Classifieds Rating: (0)
Re: 1990 camaro 305 tbi injectors wont open

i replaced the ecm but not the prom
slider07 is offline vBGarage Page   Reply With Quote
Old 03-08-2011, 02:09 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > TBI

Tags
1990, 90, alarm, bypass, bypassed, camaro, camero, computer, injectors, module, slider07, tbi, transmission, vats, working
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 09:14 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details