Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > Tech / General Engine
Register Forgot Password?

Tech / General Engine Is your car making a strange sound or won't start? Thinking of adding power with a new combination? Need other technical information or engine specific advice? Don't see another board for your problem? Post it here!
Sponsored by Weld Racing
Click Here

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 04-10-2010, 08:14 AM   #1
Senior Member
 
Join Date: Sep 2004
Location: PITTSBURGH, PA
Posts: 874
Car: 85 IROC-Z Z-28, BLUE & SILVER
Engine: 5.7L & 5.0L
Transmission: 700R4
Axle/Gears: FACTORY

Classifieds Rating: (0)

Send a message via AIM to WILL85IROC
stalling, rough idle and now it wont start!!

wassup all! i just picked up a 1985 silver iroc-z with the red graphics last month, nice ride. i went and saw it 3 times before i bought it and the guy fired it up with no problem, never drove it though til i bought it and drove it home (about 1/2 mile). he says he filled the tank and new battery. i warmed it twice a week after that until my ins and title came in. now i have both and went to drive it out of garage and guess what?? nothing!! stuck in garage... at first when i cranked it, it would take about 2 or 3 to warm up, then graduall y over the last week or so its gets worse and worse. heres my syptoms iroc drs:
1. all guages go to their correct positions when car is off, except the gas gauge, its always reading full.
2. battery between 9 and 12v, oil gauge is marginal
3. when i did get it idle, it cuts off when i go into drive and press the accelerator
4. loud wine i think from starter when i put key in and last about 12-15 seconds after i shut car off
5. wont start, keeps crank ing and clicking like its starving for fuel or lack of alt to provide enough to get going
6. no check engine light coming (not sure if it should) i was think ing i should be putting out a code or something..
7. and lastly, when the car last ran when i pulled in to garage, it idled rough and i had to press on the gas real lite and move about 1inch per hour to get into garage or would cut off.
what can i check or replace to fix: my friend has an rs with a v6 and he suggest: fuel filter, check vacuum hoses, im think ing bad alt or dirty injectors or starter motor
thanks all, need to move car soon so i can get my inspection done
__________________
WILL85IROC
WILL85IROC is offline vBGarage Page   Reply With Quote
Old 04-10-2010, 08:34 AM   #2
Senior Member
 
Join Date: Sep 2004
Location: PITTSBURGH, PA
Posts: 874
Car: 85 IROC-Z Z-28, BLUE & SILVER
Engine: 5.7L & 5.0L
Transmission: 700R4
Axle/Gears: FACTORY

Classifieds Rating: (0)

Send a message via AIM to WILL85IROC
Re: stalling, rough idle and now it wont start!!

just an fyi, i still have parts from my other 85 iroc that im restoring with all new after market parts. i want to keep the silver original as possible, so i can try parts from that car right? ex, starter, alt, reg, etc. they have been sitting for 4 years, would that matter?
WILL85IROC is offline vBGarage Page   Reply With Quote
Old 04-10-2010, 01:02 PM   #3
Senior Member
 
Join Date: Sep 2004
Location: PITTSBURGH, PA
Posts: 874
Car: 85 IROC-Z Z-28, BLUE & SILVER
Engine: 5.7L & 5.0L
Transmission: 700R4
Axle/Gears: FACTORY

Classifieds Rating: (0)

Send a message via AIM to WILL85IROC
Re: stalling, rough idle and now it wont start!!

can the starter be tested out of the car?
WILL85IROC is offline vBGarage Page   Reply With Quote
Old 04-10-2010, 01:09 PM   #4
Junior Member
 
Camarillo's Avatar
 
Join Date: Jan 2008
Location: Camarillo, California
Posts: 86
Car: 1990 RS Camaro 1991 RS
Engine: 1990 305 tbi lo3
Transmission: 700R4

Classifieds Rating: (0)
Re: stalling, rough idle and now it wont start!!

have you checked fuel pressure? Fuel pump could be going... Injectors clogged, fuel filter clogged. Plug wires laying on metal/exhaust manifold. Have you inspected distributor cap and rotor?
Camarillo is offline vBGarage Page   Reply With Quote
Old 04-10-2010, 01:26 PM   #5
Senior Member
 
Join Date: Sep 2004
Location: PITTSBURGH, PA
Posts: 874
Car: 85 IROC-Z Z-28, BLUE & SILVER
Engine: 5.7L & 5.0L
Transmission: 700R4
Axle/Gears: FACTORY

Classifieds Rating: (0)

Send a message via AIM to WILL85IROC
Re: stalling, rough idle and now it wont start!!

i checcked dist and plug connectors at that point but nothing else so far..
how do i check fuel pressure? and fuel pump?
thnx
WILL85IROC is offline vBGarage Page   Reply With Quote
Old 04-11-2010, 09:04 AM   #6
Senior Member
 
Join Date: Sep 2004
Location: PITTSBURGH, PA
Posts: 874
Car: 85 IROC-Z Z-28, BLUE & SILVER
Engine: 5.7L & 5.0L
Transmission: 700R4
Axle/Gears: FACTORY

Classifieds Rating: (0)

Send a message via AIM to WILL85IROC
Re: stalling, rough idle and now it wont start!!

put my big truck battery in the iroc and still the same results...
WILL85IROC is offline vBGarage Page   Reply With Quote
Old 04-11-2010, 03:01 PM   #7
Junior Member
 
Camarillo's Avatar
 
Join Date: Jan 2008
Location: Camarillo, California
Posts: 86
Car: 1990 RS Camaro 1991 RS
Engine: 1990 305 tbi lo3
Transmission: 700R4

Classifieds Rating: (0)
Re: stalling, rough idle and now it wont start!!

most auto parts stores will test starter alternator etc. check fuel pressure with fuel press tester/gauge. pump should whine when you turn the key, you can hear it in the trunk. Go through my recent thread "Stall Frustration, need help" to see more info.
check ignition module under dist. cap, 2 screws, 3 connectors 1 inside, 2 out. it should be well greased with di-electric grease underneath. there is a metal plate, grease dries up (i just learned this).

Last edited by Camarillo; 04-11-2010 at 03:06 PM.
Camarillo is offline vBGarage Page   Reply With Quote
Old 01-31-2011, 08:04 AM   #8
Senior Member
 
Join Date: Sep 2004
Location: PITTSBURGH, PA
Posts: 874
Car: 85 IROC-Z Z-28, BLUE & SILVER
Engine: 5.7L & 5.0L
Transmission: 700R4
Axle/Gears: FACTORY

Classifieds Rating: (0)

Send a message via AIM to WILL85IROC
Re: stalling, rough idle and now it wont start!!

i had a bad fuel pump, dropped the tank and had it replaced and now car runs strong...
WILL85IROC is offline vBGarage Page   Reply With Quote
Old 01-31-2011, 08:04 AM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > Tech / General Engine

Tags
1991, 1992, 57l, 82, bad, camaro, car, idle, idles, low, rough, stalls, start, warm, wont
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 01:48 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details