Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > TPI
Register Forgot Password?

TPI Tuned Port Injection discussion and questions. LB9 and L98 tech, porting, tuning, and bolt-on aftermarket products.
Sponsored by South Bay Fuel Injectors
Click Here

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 04-15-2008, 10:19 PM   #1
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
HELP car dies when given gas

i have a 91 TA...when i first turn it on it starts up and idles rough but when i give it gas its like it hits a wall and jus dies out..when initially started you can rev it to about thirty two grand before it starts to cut out but after that it wont go above twelve hundred RPM..

i believed it to be a fuel problem at first but the fuel pressure is right around 49 PSI at idle but when you open up the throttle it goes up to almost 60 PSI..

i have replaced the fuel pressure regulater with a new one..new Fuel filter...replaced the ignition control module with a new one..replaced the knock sensor with new...i used the MAP sensor, TPS, and IAC, off of my dads car that ran fine until it spun a rod bearing recently.

i dont think it would be the fuel pump bc it seems like it is getting plenty of fuel pressure..i need some help fast cus this is my DD, Thanks
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-15-2008, 10:36 PM   #2
Member
 
irocz28boy's Avatar
 
Join Date: Jul 2007
Location: Winter Springs, FL
Posts: 231
Car: 2000 Z28
Engine: LS1
Transmission: T-56
Axle/Gears: 10 bolt 4.10s

Classifieds Rating: (2)
Re: HELP car dies when given gas

305 or 350? That seems a little high for fuel pressure. You said you're using the TPS and IAC off your dad's car..did you make sure they were set correctly?
irocz28boy is offline vBGarage Page   Reply With Quote
Old 04-16-2008, 09:25 AM   #3
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

it is a 350TPI..i have the fuel pressure set at 50 PSI with the switch on and when you start it the PSI drops a little..

and i know that the TPS is set corrrectly im not quite sure about how to set the IAC but i dont believe it would make that kind of difference would it?
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-16-2008, 10:28 PM   #4
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

i dropped the fuel pressure down to 47 PSI adjusted the IAC it didnt work the car stil dies out at the touch of the throttle..

would a stuck injector cause this big of a problem?
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-16-2008, 10:44 PM   #5
Member
 
XxXChrisGXxX's Avatar
 
Join Date: Feb 2008
Location: Connecticut
Posts: 463
Car: 1987 Chevrolet Camaro
Engine: 2.8L V6 MPFI
Transmission: 700R4
Axle/Gears: 10 Bolt

Classifieds Rating: (1)
Send a message via AIM to XxXChrisGXxX
Re: HELP car dies when given gas

IAC is the idle air control so yes it would make a difference but completely shut the car off after some gas.

i'll give you the same advice i gave someone with the same problem.

1. Weak Fuel Pressure - Check Pressure, Check Fuel Flow, Could Possibly Be A Bad Fuel Pump

2. Check/Clean Upper Plenum, Throttle Body (Making Sure To Clean Above/Below The Throttle Body Plate), And IAC.

3. Check Idle/Timing Adjustment - Use A Timing Light To Check The Ignition Timing, Check Idle With A Tachometer (Handheld Preferable Over In Car, Or Scanner)

4. Check Your Vacuum Pressure - Use A Vacuum Gauge And Go By The Specifications On Your Car

5. Check For Leaks Of Any Kind Near Or Around The Fuel Rail

6. Could Be A Intake Gasket Gone Bad

7. Pull The Fuel Pressure Regulator Vacuum Line Check For Fuel, If Fuel Pours Out Relace The Regulator

8. Check Spark Plugs - Look For Gap Bridging (Carbon Between The Electrode And Metal Tab) Could Cause Dead Cylinders

If You Decide To Pull The Intake, Check Your Injectors Make This Your Last Resort

Hopefully Something Here Will Help You

-Christopher
XxXChrisGXxX is offline vBGarage Page   Reply With Quote
Old 04-17-2008, 10:00 AM   #6
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

well the pressure is right around 46PSI when running and around 48PSI when just the ignition is on..

Cleaning the throttle body was actually one of the first things i did but it didnt help...

i think i will try changing the timing a little bit tonight see if that helps....i checked for leaking fuel and there is none leaking anywhere...

The spark plugs and wires are brand new the car started acting up a week after i put them on so they are in good shape

My O2 sensor is maybe a month old could it possibly be that
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-17-2008, 10:22 AM   #7
Moderator
 
Kevin91Z's Avatar
 
Join Date: Jul 1999
Location: Disneyland, SoCal
Posts: 10,687
Car: 1991 Camaro Z28
Engine: 355 TPI siamesed runners
Transmission: LT1 T56
Axle/Gears: 9-Bolt 3.70

Classifieds Rating: (1)

Re: HELP car dies when given gas

Quote:
Originally Posted by thomeygun1 View Post
i believed it to be a fuel problem at first but the fuel pressure is right around 49 PSI at idle but when you open up the throttle it goes up to almost 60 PSI..
This statement leads me to believe you have a blockage in the fuel lines. Maybe in the fuel rails themselves. Perhaps a bad fuel pressure regulator?

An O2 sensor wouldnt fail in a month unless you ran leaded gas thru it, or you were so rich it was blowing black smoke out the tailpipes.
__________________
377 RWHP, 390 RWTQ (05-21-11)
12.803 @ 108.50 MPH (1.923 60') (04-11-01)
Work: Manley Performance Products
Founder: SoCal Thirdgenners
Founder: SoCal TPI Organization
Kevin91Z is offline vBGarage Page   Reply With Quote
Old 04-17-2008, 11:55 AM   #8
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

its not the fpr cus i replaced that the day it started acting up.

yea i wasnt getting any black smoke...but a blockage in the fuel rails does make sense...

i might jus swap in my slp runners with the fuel rails from my dads car and hope that solves the problem cus im out of ideas
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-21-2008, 03:21 PM   #9
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

i ran a test on my injectors here are the results
... 1:13.3 5:16.8
2:1.9 6:16.9
3:16.8 7:16.8
4:14.4 8:16.9 Ohms

is this my problem..would a couple of bad injectors cause my car to die at the touch of the throttle?
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-22-2008, 01:25 AM   #10
Moderator
 
Kevin91Z's Avatar
 
Join Date: Jul 1999
Location: Disneyland, SoCal
Posts: 10,687
Car: 1991 Camaro Z28
Engine: 355 TPI siamesed runners
Transmission: LT1 T56
Axle/Gears: 9-Bolt 3.70

Classifieds Rating: (1)

Re: HELP car dies when given gas

That #2 with 1.9 ohms is definitely a problem. See if you can find someone with an extra or just replace the whole set.
Kevin91Z is offline vBGarage Page   Reply With Quote
Old 04-22-2008, 08:39 PM   #11
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

im just going to replace all the injectors with 30lb bosch injectors..

would these be ok for a while until i get my computer tuned?
----------
Click the image to open in full size.
are these good injectors?

Last edited by thomeygun1; 04-22-2008 at 08:41 PM. Reason: Automerged Doublepost
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-22-2008, 09:47 PM   #12
Member
 
irocz28boy's Avatar
 
Join Date: Jul 2007
Location: Winter Springs, FL
Posts: 231
Car: 2000 Z28
Engine: LS1
Transmission: T-56
Axle/Gears: 10 bolt 4.10s

Classifieds Rating: (2)
Re: HELP car dies when given gas

The injectors are good, yes, but 30lbs? Are you planning on heavily modding this engine? I wouldn't do anymore than 24lbs with a stock L98. They can handle plenty of power themselves.
irocz28boy is offline vBGarage Page   Reply With Quote
Old 04-23-2008, 03:57 PM   #13
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

the engine will be modded some for now..

it has a cam with i believe 270/280 duration and like .460/.474 lift im not sure exactly i dont have the cam card on me right now and im also putting the sdpc base on it, slp runners, and porting the plenum..it also has 3.73 gaers and a corvette stall
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-23-2008, 05:18 PM   #14
Supreme Member
 
afremont's Avatar
 
Join Date: Feb 2008
Posts: 1,002
Car: 90 IROC
Engine: 5.7 TPI
Transmission: 4L60
Axle/Gears: 3.23

Classifieds Rating: (0)
Re: HELP car dies when given gas

Quote:
Originally Posted by thomeygun1 View Post
i believed it to be a fuel problem at first but the fuel pressure is right around 49 PSI at idle but when you open up the throttle it goes up to almost 60 PSI..
The factory (multics) injectors can stop flowing when the pressure gets to right around 60PSI.
afremont is offline vBGarage Page   Reply With Quote
Old 04-25-2008, 01:30 AM   #15
Moderator
 
Kevin91Z's Avatar
 
Join Date: Jul 1999
Location: Disneyland, SoCal
Posts: 10,687
Car: 1991 Camaro Z28
Engine: 355 TPI siamesed runners
Transmission: LT1 T56
Axle/Gears: 9-Bolt 3.70

Classifieds Rating: (1)

Re: HELP car dies when given gas

The engine will run pig rich with 30lbs injectors and the stock chip. You dont need 30lbs until you install heads, cam, and a higher RPM intake. 24lbs are just fine but it will run slightly rich until you get the computer tuned.
Kevin91Z is offline vBGarage Page   Reply With Quote
Old 04-26-2008, 08:57 PM   #16
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

alright i dont think im going 30lb injectors...i think i will go with the 26lb venoms
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 04-27-2008, 01:32 AM   #17
Member
 
irocz28boy's Avatar
 
Join Date: Jul 2007
Location: Winter Springs, FL
Posts: 231
Car: 2000 Z28
Engine: LS1
Transmission: T-56
Axle/Gears: 10 bolt 4.10s

Classifieds Rating: (2)
Re: HELP car dies when given gas

If it's going to run a little rich with 24lb injectors, what do you think it'll do with 26lb? At least tune the computer as soon as possible when you put those injectors in.
irocz28boy is offline vBGarage Page   Reply With Quote
Old 05-05-2008, 12:08 PM   #18
Junior Member
 
thomeygun1's Avatar
 
Join Date: Jul 2007
Location: WV
Posts: 24
Car: 91 TA
Engine: L98
Transmission: 700r4
Axle/Gears: 3.73

Classifieds Rating: (0)
Re: HELP car dies when given gas

So i replaced my injectors this past weekend and it turned out to be the problem...i took your guys advice and went with 24lb injectors...that bad injector was probably stuck closed and when i gave it gas it caused the fuel pressure to shoot up to 60psi and then the injectors would quit working
Thanks for the help!
thomeygun1 is offline vBGarage Page   Reply With Quote
Old 05-05-2008, 12:08 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > TPI

Tags
1991, 2000, car, dies, firebird, gas, give, giving, idles, pig, rich, runs, starts, touch, tpi
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 03:13 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details