Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > TPI
Register Forgot Password?

TPI Tuned Port Injection discussion and questions. LB9 and L98 tech, porting, tuning, and bolt-on aftermarket products.
Sponsored by South Bay Fuel Injectors
Click Here

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 04-15-2010, 10:02 AM   #1
Junior Member
 
Join Date: Dec 2006
Posts: 67
Car: 92 formula w/t-tops
Engine: 350 (L98) 5.7 TPI
Transmission: 700-R4
Axle/Gears: 3.27

Classifieds Rating: (0)
TPS bad?

I was hoping to get some opinions on this.
I am having a high/fluctuating idle. Sometimes a hesitation on go and even a jerking of the car (nothing too severe, but made me think that was a trannsmission problem) when driving down the road at times.

I am getting error code 22, which says "faulty tps" or "bad fuel pump relay".

Since I started getting the code, it'll go away for a couple days and then come back on. When on it will usally go off after accelerating and then when I get to a certain speed, it will come back on.

Do those symptoms say "bad tps" or am I really looking at a bad fuel pump relay?
NiteStar is offline vBGarage Page   Reply With Quote
Old 04-15-2010, 11:30 AM   #2
On Probation
 
Chevy86 IROC-Z's Avatar
 
Join Date: May 2009
Location: Far West
Posts: 4,742
Car: 1986 Camaro Z28 IROC-Z
Engine: 350 Tuned Port Injection, for now.
Transmission: 700R4
Axle/Gears: Posi - 3.23

Classifieds Rating: (17)
Send a message via Skype™ to Chevy86 IROC-Z
Re: TPS bad?

You may need to tune up your TPI system first. Read and perform the tune up process then let me know what the results in performance. Is your Formula Speed Density or Mass Air Flow?
Tune up link is here....
http://74.125.155.132/search?q=cache...&ct=clnk&gl=us

http://mpikas.blogspot.com/2008/08/t...june-2000.html
Chevy86 IROC-Z is offline vBGarage Page   Reply With Quote
Old 04-15-2010, 12:39 PM   #3
Junior Member
 
Join Date: Dec 2006
Posts: 67
Car: 92 formula w/t-tops
Engine: 350 (L98) 5.7 TPI
Transmission: 700-R4
Axle/Gears: 3.27

Classifieds Rating: (0)
Re: TPS bad?

It's a Speed Density system.

I've replaced the Ignition Module, Igntion Coil and battery. The spark plugs, wires, cap and rotor are about 6 months old.

Last edited by NiteStar; 04-15-2010 at 02:19 PM.
NiteStar is offline vBGarage Page   Reply With Quote
Old 04-15-2010, 01:58 PM   #4
Junior Member
 
Join Date: Dec 2006
Posts: 67
Car: 92 formula w/t-tops
Engine: 350 (L98) 5.7 TPI
Transmission: 700-R4
Axle/Gears: 3.27

Classifieds Rating: (0)
Re: TPS bad?

btw another symptom/problem is...

Just now it was idling very high @ 1200 rpm. When it does this, sometimes it'll come down after 5-10 minutes or I just shut it off. I pressed the gas peddle a quick 2X and noticed it can help make it go down to idle @ 700. After a minute longer it started jumping down to 3-400 rpm and fluctuation and almost stalling. I tried pressing the gas pedal but it did nothing. Smoke was coming out the back (I assume it was flooding so it was gas). I'm scared to drive it. Seemed though like just shutting off the car and starting right back up, made it go back to normal.
NiteStar is offline vBGarage Page   Reply With Quote
Old 04-15-2010, 04:19 PM   #5
On Probation
 
Chevy86 IROC-Z's Avatar
 
Join Date: May 2009
Location: Far West
Posts: 4,742
Car: 1986 Camaro Z28 IROC-Z
Engine: 350 Tuned Port Injection, for now.
Transmission: 700R4
Axle/Gears: Posi - 3.23

Classifieds Rating: (17)
Send a message via Skype™ to Chevy86 IROC-Z
Re: TPS bad?

Sure sounds like a bad TPS. All that it does is it tells the ECM that the throttle plates are open and to adjust how much fuel to inject via fuel injectors. So if the TPS is faulty, it may send a false voltage reading to the ECM and the ECM will then think that the gas peddle is being pressed which them the ECM adjusts the fuel injectors and will begin to throw more fuel while there is insufficient air thus causing bad idle or stalling because of the bad air/fuel ratio mixture. Buy a new TPS and adjust it. Its only about $20. Im almost certain thats whats causing the issue.
Chevy86 IROC-Z is offline vBGarage Page   Reply With Quote
Old 04-15-2010, 05:14 PM   #6
Junior Member
 
Join Date: Dec 2006
Posts: 67
Car: 92 formula w/t-tops
Engine: 350 (L98) 5.7 TPI
Transmission: 700-R4
Axle/Gears: 3.27

Classifieds Rating: (0)
Re: TPS bad?

I hope so Chevy. I have the TPS on order to pick up first thing tomorrow. I'll let u know either way. Right now, I'm afraid to drive it for fear it dies while driving. It happened this morning and it was like I ran out of gas, but of course I hadn't.
NiteStar is offline vBGarage Page   Reply With Quote
Old 04-21-2010, 02:04 AM   #7
Junior Member
 
Join Date: Dec 2006
Posts: 67
Car: 92 formula w/t-tops
Engine: 350 (L98) 5.7 TPI
Transmission: 700-R4
Axle/Gears: 3.27

Classifieds Rating: (0)
Re: TPS bad?

Just wanted you to know Chevy86, that changing the TPS fixed my high idle fluctuations and the other problems I mentioned. Thanks for the help.
NiteStar is offline vBGarage Page   Reply With Quote
Old 04-21-2010, 01:27 PM   #8
On Probation
 
Chevy86 IROC-Z's Avatar
 
Join Date: May 2009
Location: Far West
Posts: 4,742
Car: 1986 Camaro Z28 IROC-Z
Engine: 350 Tuned Port Injection, for now.
Transmission: 700R4
Axle/Gears: Posi - 3.23

Classifieds Rating: (17)
Send a message via Skype™ to Chevy86 IROC-Z
Re: TPS bad?

Very, Nice bro. Im happy that you nailed the issue. Alright bro, take it easy and drive safe. Peace .
Chevy86 IROC-Z is offline vBGarage Page   Reply With Quote
Old 04-21-2010, 01:27 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > TPI

Tags
1988, 2009, 57, bad, chevy, code, drive, irocz, position, sensor, throttle, tpi, tps, transmission, wire
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 07:48 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details