Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > V6
Register Forgot Password?

V6 Discussion and questions about the base carbureted or MPFI V6's and the rare SFI Turbo V6.

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 01-26-2010, 03:00 PM   #1
Junior Member
 
Join Date: Sep 2009
Posts: 73
Car: 92 Camaro RS
Engine: 3.1l V6 .40 Over

Classifieds Rating: (0)
92 Camaro High Idle Problem, Any Help?

Ok, I have a 92 Camaro, RS. Its got the 3.1L v6 in it. The car is in really good shape. The car has been sitting for just about 10 years. And it hadnt been started in almost 3 years. So i did some preventative maintenance to the car. (Oil change, cleaned the plugs, a lil MM Oil in the plug hole / cyl )

After a few different things going wrong, rotted fuel lines, locked smog pump, every vaccum line under the hood rotted....ect. I got the car running. After a little persuasion and some good gas it started up no problem. However the Idle is sitting around 3,000 or higher rpm. Me and a buddy let it run for about 15 mins it warmed up no prob. Guages all work, no check engine lights, no prob. The last thought i had was to stomp on teh gas pedal and see if it would act like the electric choke on my 85 el camino. and the car rev'd up great and the idle droped to around 1000 rpm.

However whenever you touch the gas now it shoots back up to around 3000-3500 and u have to kick it back down.

I have a good friend who is a license mechanic, and said it would be the TPS, IAC (maybe), or that the ECM has to relearn the "idle position" after driving it for about 5-30 miles...since the car has had a dead battery for basically 10 years.

I trust his oppinions but i always like to get extra advice from ppl. So if you have any idea or if this has happened to you please help me out if u can.

davila0115 is offline vBGarage Page   Reply With Quote
Old 01-26-2010, 08:21 PM   #2
Senior Member
 
firebird904's Avatar
 
Join Date: Feb 2009
Location: Jacksonville FL
Posts: 592
Car: 1988 camaro
Engine: cammed 3.1
Transmission: 700r4
Axle/Gears: 10 bolt 3.42

Classifieds Rating: (0)
Re: 92 Camaro High Idle Problem, Any Help?

I just got done getting my camaro's engine running right after 8 years of rest i replaced all the vacuum hoses, did a tune up, changed iac valve, and maf sensor and now it runs great. Your problem sounds to me like maybe there is still a vacuum hose either cracked or not connected causing it to idle high take a can of starter fluid and spray it around the vacuum hoses and see if the idle changes. Also be prepared to replace sensors after it sitting so long while the engine may be good after sitting electrical parts corrode over time.
firebird904 is offline vBGarage Page   Reply With Quote
Old 01-26-2010, 10:14 PM   #3
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,121
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 92 Camaro High Idle Problem, Any Help?

While I will agree that you need to take it out for a drive (to get the fluids moving again), you need to do an idle relearn procedure first. However, thie problem you describe is caused by the TPS. It's not adjusted properly. Check the voltage reading between the blue wire and the black one. My guess is that it's around .72 VDC (maybe higher), so the computer thinks the throttle is something like 20% open.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 01-26-2010, 10:14 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > V6

Tags
1992, 5, 91, 92, body, camaro, high, idle, idling, idol, manifold, problem, problems, sensor, speed, tune
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 04:27 AM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details