Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > Electronics
Register Forgot Password?

Electronics Need help wiring something up? Thinking of adding an electrical component to your car? Need help troubleshooting that wiring glitch?

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 12-04-2011, 04:05 PM   #1
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
ecm keeps blowing fuse

The other day my alternator went out while I was driving home so I kept going to try to make it there before the battery fully died, didn't make it, but I got a new alternator and charged the battery and now the ecm fuse keeps popping I've gone through half of my fuses trying to figure it out. The fuel pump is new and had it put in at a shop, but I'm stumped and need some help
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 04:52 PM   #2
Supreme Member
 
travis401's Avatar
 
Join Date: Mar 2007
Location: Arlington, Tx
Posts: 3,524
Car: 91 Camaro RS
Engine: empty bay (for now)
Transmission: Built T-56
Axle/Gears: 3.42 stock posi disc

Classifieds Rating: (1)
Re: ecm keeps blowing fuse

its blowing because its drawing more amps than the fuse can handle. the ecm power circuit is either grouning out on something, or something is wired into it that shouldnt be.
http://austinthirdgen.org/mkportal/m...ine_wiring.gif
btw, were in arlington are you?
travis401 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 05:00 PM   #3
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
Re: ecm keeps blowing fuse

Central Arlington ,the closest intersection is Arkansas ln and fielder rd, it hasn't given me any problems before it died
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 05:02 PM   #4
Supreme Member
 
travis401's Avatar
 
Join Date: Mar 2007
Location: Arlington, Tx
Posts: 3,524
Car: 91 Camaro RS
Engine: empty bay (for now)
Transmission: Built T-56
Axle/Gears: 3.42 stock posi disc

Classifieds Rating: (1)
Re: ecm keeps blowing fuse

i used to work at ricks autobody off arkansas and cooper. its possbile that when the alt died, it took something else out with it thats causing the issues.


you should check out nttga.net, its a 3rd gen group here in dfw.
travis401 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 05:07 PM   #5
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
Re: ecm keeps blowing fuse

That's not far away at all lol, what all wires go to the positive battery terminal? I just noticed some frayed wires
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 05:12 PM   #6
Supreme Member
 
travis401's Avatar
 
Join Date: Mar 2007
Location: Arlington, Tx
Posts: 3,524
Car: 91 Camaro RS
Engine: empty bay (for now)
Transmission: Built T-56
Axle/Gears: 3.42 stock posi disc

Classifieds Rating: (1)
Re: ecm keeps blowing fuse

ecm gets its power from the pnk wire with black strip thats on the c1 plug at position a8. the VATs module and ESC module also get their power from the ECM fuse.
travis401 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 05:13 PM   #7
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
Re: ecm keeps blowing fuse

No vats on mine
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 05:58 PM   #8
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
Re: ecm keeps blowing fuse

The fuse thats popping is the inline one by the battery
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 06:09 PM   #9
Supreme Member
 
travis401's Avatar
 
Join Date: Mar 2007
Location: Arlington, Tx
Posts: 3,524
Car: 91 Camaro RS
Engine: empty bay (for now)
Transmission: Built T-56
Axle/Gears: 3.42 stock posi disc

Classifieds Rating: (1)
Re: ecm keeps blowing fuse

that fuse is for the battery voltage for the ecm and the fuel pump relay. can you check to make sure the relay isnt fried? or that the wire isnt melted and grounding out on anything
travis401 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 06:14 PM   #10
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
Re: ecm keeps blowing fuse

I just replaced the relay today
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 06:23 PM   #11
Supreme Member
 
travis401's Avatar
 
Join Date: Mar 2007
Location: Arlington, Tx
Posts: 3,524
Car: 91 Camaro RS
Engine: empty bay (for now)
Transmission: Built T-56
Axle/Gears: 3.42 stock posi disc

Classifieds Rating: (1)
Re: ecm keeps blowing fuse

and the fuse started blowing after that? if thats the case id pull the relay off and see if it stops blowing. if it does then you found the problem
travis401 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 06:35 PM   #12
Junior Member
 
Join Date: Apr 2011
Location: Arlington, Tx
Posts: 96
Car: 1988 T/A
Engine: 305 TBI
Transmission: 700r4

Classifieds Rating: (0)
Re: ecm keeps blowing fuse

I found it its the relay harness
ROADKILL76 is offline vBGarage Page   Reply With Quote
Old 12-04-2011, 06:35 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > Electronics
« fuel pump | Fuse? »

Tags
91, alternator, arlington, battery, blowing, blown, body, camaro, car, classifieds, ecm, esc, fuse, powered, rs, tx, vbulletin
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 02:34 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details