Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > Engine Swap > LTX and LSX
Register Forgot Password?

LTX and LSX Putting LT1s, LS1s, and their variants into Third Gens is becoming more popular. This board is for those who are doing and have done the swaps so they can discuss all of their technical aspects including repairs, swap info, and performance upgrades.

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 10-02-2011, 01:58 PM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 9

Classifieds Rating: (0)
1995 Camaro LT1/T56 high idle!

Hi guys,

My 1995 Camaro LT1/T56 combo transplant in a 1984 Jaguar xj6 is suffering from high idle. It idles at around 1400-1500. I have done the following:

I investigated for an intake leak, and didn't find one -- I replaced the intake gaskets again for good measure and torqued everything down to spec. Still it is idling high.

I replaced the IAC.

I've checked for other intake leaks at the brake booster.

I replaced my MAF.

I tried Re-setting the IAC (holding the accelerator pedal down slightly on startup and then letting go after 5-10 seconds)


I'm not sure what else it could be -- the car threw one code (the fans clicked on, so I decided to check out what the code was) but when I scanned the PCM, there were no trouble codes stored.

Since my Speedo isn't working (i tried solving that one a couple weeks ago) i could have a VSS problem -- does the VSS partially control idle?

I don't know what the problem could be -- does anyone have any suggestions? I feel like i've exhausted all options. One of my friends says it could be that the timing is off, but the engine isn't running rough, just a high idle.

What else could I try? Since the car is a conversion most mechanics are reluctant to work on it, and I've done all the other work on the darn thing I'd like to figure it out on my own, but it's diving me nuts!

Thanks for any help!
tylerwerrin is offline vBGarage Page   Reply With Quote
Old 05-07-2013, 01:38 PM   #2
Junior Member
 
Join Date: May 2013
Posts: 1

Classifieds Rating: (0)
Re: 1995 Camaro LT1/T56 high idle!

I had the same high idle problem. I just solved it by replacing my mass air flow sensor, IAC valve, and tps sensor now my car is idling normal and fan only come on when needed. The fan issue was due to the error codes, once that was solved they operate normal. hopes this helps.
James Paschal is offline vBGarage Page   Reply With Quote
Old 05-23-2013, 03:28 PM   #3
Junior Member
 
Join Date: Aug 2011
Location: NW Chicago Burbs
Posts: 5
Car: 94 Z-28, Cam, Heads, Intake
Engine: LT1
Transmission: T-56
Axle/Gears: 3.90

Classifieds Rating: (0)
Re: 1995 Camaro LT1/T56 high idle!

Whats the voltage on the TPS? Is it set correctly? Does the idle spike if you spray brake clean around the intake?
Rsd94Z is offline vBGarage Page   Reply With Quote
Old 05-23-2013, 03:28 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > Engine Swap > LTX and LSX

Tags
1400, 1995, 95, adjust, base, camaro, gen, high, idle, idles, idling, lt1, maf, running, t56
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 10:21 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.5.2
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details