Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > Tech / General Engine
Register Forgot Password?

Tech / General Engine Is your car making a strange sound or won't start? Thinking of adding power with a new combination? Need other technical information or engine specific advice? Don't see another board for your problem? Post it here!
Sponsored by Weld Racing
Click Here

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 04-14-2005, 11:31 AM   #1
Junior Member
 
Join Date: Mar 2005
Location: NM
Posts: 53
Car: 89 camaro rs
Engine: 305 TBI
Transmission: 700R4

Classifieds Rating: (0)
How can you tell if a knock sensor is bad?

I would just like to know some of the symptoms of a bad knock sensor. My 89 305 TBI is pinging when it's warm, and it doesn't seem to change when I put different fuel in. It idles strange too; when it's warm and you've been romping on it, it can't keep a steady idle speed. This changes though a little depending on the gas you put in. It has even died on me a couple of times at a stop light, but always starts back up again. Performance hasn't changed noticeably, and I'm still getting around 20 mpg average. No trouble codes either. It's not the EGR valve or anything that has to do with the TB.
Any ideas?
white80zred89rs is offline vBGarage Page   Reply With Quote
Old 04-14-2005, 03:15 PM   #2
Supreme Member
 
paulo57509's Avatar
 
Join Date: Jan 2000
Location: Tracy, CA
Posts: 1,695
Car: '87 IROC
Engine: 305 ci
Transmission: TH700R4

Classifieds Rating: (0)

There was a time where you could watch the timing marks with a timing light, lightly rap on the exhaust manifold with a hammer and if the knock sensor was working, you can watch the timing marks retard.
paulo57509 is offline vBGarage Page   Reply With Quote
Old 04-14-2005, 10:34 PM   #3
Junior Member
 
Join Date: Mar 2005
Location: NM
Posts: 53
Car: 89 camaro rs
Engine: 305 TBI
Transmission: 700R4

Classifieds Rating: (0)
Where is the knock sensor located anyway? I heard that there may be more than one also; is that the case on an 89 305 TBI?
white80zred89rs is offline vBGarage Page   Reply With Quote
Old 04-15-2005, 11:07 PM   #4
Senior Member
 
Join Date: Nov 2002
Posts: 638
Car: 89 trans am
Engine: 355
Transmission: 700r4

Classifieds Rating: (0)
Send a message via AIM to trans_am_ta_84
it's on the passenger side of the block and i beleive it's under the manifold.
trans_am_ta_84 is offline vBGarage Page   Reply With Quote
Old 04-16-2005, 02:30 AM   #5
Moderator
 
Air_Adam's Avatar
 
Join Date: Oct 2002
Location: Saskatoon, SK, Canada
Posts: 9,067
Car: '83 Z28, '07 Charger SRT8
Engine: 454ci, 6.1 Hemi
Transmission: TH350, A5
Axle/Gears: 2.73 posi, 3.06 posi

Classifieds Rating: (0)

Send a message via MSN to Air_Adam
Quote:
Originally posted by white80zred89rs
Where is the knock sensor located anyway?
Passenger side coolant drain hole... its right near the starter.
Air_Adam is offline vBGarage Page   Reply With Quote
Old 04-16-2005, 10:38 PM   #6
Member
 
Join Date: Oct 2004
Location: Yuma, AZ
Posts: 145
Car: 1992 camaro rs T-top
Engine: 305 ci V8 TBI

Classifieds Rating: (0)
what happens if your knocksenser is not hooked up? becuase my car runs fine but i think it's a little weak than it should be.
and oh it might be the 170000 miles on the car lol
3rd gen V8 is offline vBGarage Page   Reply With Quote
Old 04-17-2005, 01:07 AM   #7
Moderator
 
Air_Adam's Avatar
 
Join Date: Oct 2002
Location: Saskatoon, SK, Canada
Posts: 9,067
Car: '83 Z28, '07 Charger SRT8
Engine: 454ci, 6.1 Hemi
Transmission: TH350, A5
Axle/Gears: 2.73 posi, 3.06 posi

Classifieds Rating: (0)

Send a message via MSN to Air_Adam
If its not hooked up, IIRC, it will go into a preset "limp home" mode, which seriously kills everything... no power, poor running, and bad mileage.
Air_Adam is offline vBGarage Page   Reply With Quote
Old 04-17-2005, 09:55 AM   #8
Senior Member
 
Join Date: Nov 2002
Posts: 638
Car: 89 trans am
Engine: 355
Transmission: 700r4

Classifieds Rating: (0)
Send a message via AIM to trans_am_ta_84
well like air adam said it won't be alittle weak it will be like running on 5 cylinders. it retards the timing and then the car won't even want to move.
trans_am_ta_84 is offline vBGarage Page   Reply With Quote
Old 04-17-2005, 11:01 AM   #9
Member
 
Join Date: Oct 2004
Location: Yuma, AZ
Posts: 145
Car: 1992 camaro rs T-top
Engine: 305 ci V8 TBI

Classifieds Rating: (0)
well my car drives just fine thoe but the sensor is unpluged and i cant find the wire that went to it either.
3rd gen V8 is offline vBGarage Page   Reply With Quote
Old 04-17-2005, 12:04 PM   #10
Supreme Member
 
92rs85berlintta's Avatar
 
Join Date: Feb 2003
Location: check under the car
Posts: 1,134
Car: White 25th Anniversary RS
Engine: lt1
Transmission: t56
Axle/Gears: 4:10

Classifieds Rating: (1)

Send a message via AIM to 92rs85berlintta
pull it out put a volt meter on it and tap it with a piece of metal and see if the reading jump between .5-1.5 volt or somere around that. put the black volt meter prong on the threads and the red on the connector.
92rs85berlintta is offline vBGarage Page   Reply With Quote
Old 04-17-2005, 12:04 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > Tech / General Engine

Tags
1989, 350, 89, bad, camaro, car, effects, knock, lt1, sensor, start, symptoms, tbi, trans, warm
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 04:35 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details