Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > Tech / General Engine
Register Forgot Password?

Tech / General Engine Is your car making a strange sound or won't start? Thinking of adding power with a new combination? Need other technical information or engine specific advice? Don't see another board for your problem? Post it here!
Sponsored by Weld Racing
Click Here

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 01-03-2008, 12:41 PM   #1
Junior Member
 
neo01453's Avatar
 
Join Date: Jan 2006
Location: Colorado Springs, Co.
Posts: 35
Car: 91 z28
Engine: 350tpi
Transmission: 700r4

Classifieds Rating: (2)
91 5.7 oil pressure drops when let off gas

I was driving my car today and stopped somewhere for five minutes to get back in my car and it didn't want to stay running. Eventually after getting it some gas it stayed running just enough to get it moving. The oil pressure is fine moving down the road but once you let off the gas it completly drops to nothing and the idle is very low. This car was mainly a weekend driver/ project. The last few weeks i've been drinving it daily due to my daily driver being out of commission. I've only but about 6,000 miles on it the 3 years i've owned it mainly due to high gas prices, but the milage is at 152,000, with no engine mods except a hypertech chip. Any Info on what could be wrong would be greatly apreciated. thanks
neo01453 is offline vBGarage Page   Reply With Quote
Old 01-03-2008, 01:57 PM   #2
Moderator
 
Air_Adam's Avatar
 
Join Date: Oct 2002
Location: Saskatoon, SK, Canada
Posts: 9,067
Car: '83 Z28, '07 Charger SRT8
Engine: 454ci, 6.1 Hemi
Transmission: TH350, A5
Axle/Gears: 2.73 posi, 3.06 posi

Classifieds Rating: (0)

Send a message via MSN to Air_Adam
Re: 91 5.7 oil pressure drops when let off gas

What noises, if anything, does the engine make when it does run? clicking? clanking? Does it smoke? Is it running rough/stalling?

Have you checked the oil - what does it look like? does it look full? How about the cooling system - what does the coolant look like? Is it full?

If the oil pressure is reading low, check it with a mechanical guage first - the electric factory units are famous for going bad over time, and they read low 99% of the time when they start to fail. Checking the oil pressure with a mechanical guage will tell you what it really is. You can buy a guage at most parts stores for about $15-20. There are places to hook it up on the engine block above the oil filter, and under the distributor. The spot above the oil filter is probably where your electric sender is located. Take it out and hook up the mechanical guage, start the engine and see what it reads.

If the engine is idling very low (around 500 is normal for TPI IIRC) then that could be a cause of low oil pressure - the oil pump is mechanically driven by the engine, so the lower the engine speed, the lower the oil pressure, all else being equal.

Last edited by Air_Adam; 01-03-2008 at 02:01 PM.
Air_Adam is offline vBGarage Page   Reply With Quote
Old 01-03-2008, 02:21 PM   #3
Junior Member
 
neo01453's Avatar
 
Join Date: Jan 2006
Location: Colorado Springs, Co.
Posts: 35
Car: 91 z28
Engine: 350tpi
Transmission: 700r4

Classifieds Rating: (2)
Re: 91 5.7 oil pressure drops when let off gas

the intake has a minor leak of coolant, not enough to make it overheat. but it's not smoking, knocking, or anything seems very normal down the road. oil is good, i just changed it a month ago and only put 500 miles on it. i pulled over and checked it when it started acting up. but when i go to aproach a stop light and let off the gas the car idles way down to barely nothing like 200-300 rpm, just enought to stay running but as i got closer to home it was stalling more and more.
neo01453 is offline vBGarage Page   Reply With Quote
Old 01-04-2008, 02:08 PM   #4
Junior Member
 
neo01453's Avatar
 
Join Date: Jan 2006
Location: Colorado Springs, Co.
Posts: 35
Car: 91 z28
Engine: 350tpi
Transmission: 700r4

Classifieds Rating: (2)
Re: 91 5.7 oil pressure drops when let off gas

could this be the fuel pump failing?? because it will only start if given gas by pressing the gas pedal and runs fine, but when i let off it, it just dies, anybody have any ideas, thanks any feed back is much appreciated
neo01453 is offline vBGarage Page   Reply With Quote
Old 01-04-2008, 02:28 PM   #5
Moderator
 
Air_Adam's Avatar
 
Join Date: Oct 2002
Location: Saskatoon, SK, Canada
Posts: 9,067
Car: '83 Z28, '07 Charger SRT8
Engine: 454ci, 6.1 Hemi
Transmission: TH350, A5
Axle/Gears: 2.73 posi, 3.06 posi

Classifieds Rating: (0)

Send a message via MSN to Air_Adam
Re: 91 5.7 oil pressure drops when let off gas

Quote:
Originally Posted by neo01453 View Post
could this be the fuel pump failing?? because it will only start if given gas by pressing the gas pedal and runs fine, but when i let off it, it just dies, anybody have any ideas, thanks any feed back is much appreciated
Its possible - but pumping the throttle on an EFI engine will not make any difference, unlike a carb'd engine. The only time holding the throttle open can help with EFI is if its flooded.

Have you check fuel pressure?
Air_Adam is offline vBGarage Page   Reply With Quote
Old 01-04-2008, 02:34 PM   #6
Junior Member
 
neo01453's Avatar
 
Join Date: Jan 2006
Location: Colorado Springs, Co.
Posts: 35
Car: 91 z28
Engine: 350tpi
Transmission: 700r4

Classifieds Rating: (2)
Re: 91 5.7 oil pressure drops when let off gas

haven't checked it, and not really sure how to.
neo01453 is offline vBGarage Page   Reply With Quote
Old 01-04-2008, 02:34 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > Tech / General Engine

Tags
57, 91, drops, engine, gas, idling, letting, loses, low, oil, pressure, rpm, sensor, smoke, z28
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 06:24 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details