Pendling idle and with throotle in closed loop - Third Generation F-Body Message Boards


TPI Tuned Port Injection discussion and questions. LB9 and L98 tech, porting, tuning, and bolt-on aftermarket products.
Sponsored by:
Sponsored by:

Pendling idle and with throotle in closed loop

Reply
 
Thread Tools Search this Thread
Old 07-10-2018, 04:36 PM   #1  
Junior Member
Thread Starter
 
Greengurkan's Avatar
 
Join Date: Jul 2017
Location: Sweden
Posts: 9
Car: 91 Camaro Z28 Convertible
Engine: 5.0 L TPI
Transmission: M39 5-speed manual
Axle/Gears: G80 Limited Slip 3.08

Pendling idle and with throotle in closed loop

Hi,


I got a Z28 1991 manual with a 5.0 TPI.


In cold start and open loop it runs fine but after a 10-15 min drive when she goes into closed loop, then the idle starts going between 500-800 RPM and also when driven with a little throttle the same result happens but at a higher RPM of course, hard to drive too. If you give her more gas you can feel it's not the same performance as ion open loop.



Since she runs good in open loop so I get a little confused what's causing this problem which happens only in closed loop.



I did a test today when this happend, I stopped the engine, pulled away the temp sensor connector for the ECM and started her up.

No problems since she was running in open loop.



I checked for Error codes but there aren't any.



Like 400 miles ago every ignition part was replaced incl. injectors.


Need help!!



Thanks!
/Magnus
Greengurkan is offline   Reply With Quote
Old 07-11-2018, 11:08 AM   #2  
Member
 
Go Blue's Avatar
 
Join Date: Sep 2017
Location: Huntley, IL
Posts: 156
Car: 88 Chevy IROC Z28
Engine: 5.7L TPI
Transmission: 700R4

Re: Pendling idle and with throotle in closed loop

Have you tried spraying brake clean around the intake manifold and checking for vacuum leaks after the engine is warmed up? It almost seems like 1 or more sensors have a faulty reading but they aren't out of the "OK" range enough to set an error code. Tuned Performance is a great person to reach out to and ask this question to. He's great at diagnosing driveability issues!
Go Blue is offline   Reply With Quote
Old 07-11-2018, 11:42 AM   #3  
Sponsor
iTrader: (79)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 10,267
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt


Re: Pendling idle and with throotle in closed loop

The only thing I can think of is a silicone poisoned oxygen sensor.
Tuned Performance is offline   Reply With Quote
Old 07-11-2018, 11:32 PM   #4  
Pro
Senior Member
 
Join Date: Oct 2003
Location: DFW
Posts: 943
Car: 1992 Z28 and 1995 Silverado
Engine: 5.7 TPI and 5.7 TBI to TPI convert
Transmission: 700R4 and 4l60E
Axle/Gears: G80 3.23 and open 3.42


Re: Pendling idle and with throotle in closed loop

No error codes when you disconnected the temp sensor?
Pro is offline   Reply With Quote
Old 07-12-2018, 04:46 PM   #5  
Sponsor
iTrader: (79)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 10,267
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt


Re: Pendling idle and with throotle in closed loop

Tuned Performance is offline   Reply With Quote
Old 07-13-2018, 08:21 AM   #6  
Junior Member
Thread Starter
 
Greengurkan's Avatar
 
Join Date: Jul 2017
Location: Sweden
Posts: 9
Car: 91 Camaro Z28 Convertible
Engine: 5.0 L TPI
Transmission: M39 5-speed manual
Axle/Gears: G80 Limited Slip 3.08

Re: Pendling idle and with throotle in closed loop

Hi, and thanks for the replies!


Update,



Yes, after I disconnected the temp sensor I got an Error code 15 so I connected it back again.



Yesterday I changed the o2 sensor to an ACDelco but the same idle sourge occured when the engine got warm. Also the engine shakes a little when the car gets into closed loop, you can fell it when it happens and you loose enginepower as well. It's hard to keep the engine at idle, it's surguing between 500-1000 rpm and it takes like a second, up-down, up-down.......



I stopped for a while and disconnected the tempsensor again to make the car go into open loop but the same sourging occured so I guess it was still in closed loop.

I parked the car for an hour, disconnected the o2 sensor and drove home again, this time nothing happend except some sourging around 1500 rpm.


I have a AC that works except the it's not blowing any cold air. I think the system is empty, can the AC have something to do with this? Is the AC connected to the ECM?


I read that this engines ar working under pretty high temperature. I measured the ohm on the temp-sensor and translated it to app. 217F, I also measured the ohm on the temp-sensor for the gauge and translated that to app. 215 F.


I will check for vaccum leaks.


I'm just confused when the engine runs pretty fine in open loop but goes bad in closed loop......


//Magnus
Greengurkan is offline   Reply With Quote
Old 07-13-2018, 09:07 AM   #7  
Member
 
Go Blue's Avatar
 
Join Date: Sep 2017
Location: Huntley, IL
Posts: 156
Car: 88 Chevy IROC Z28
Engine: 5.7L TPI
Transmission: 700R4

Re: Pendling idle and with throotle in closed loop

The AC fan and compressor are controlled by the ECM in terms of the ECM monitoring the pressure sensors to make sure that the R12 or R134a isn't too low or there isn't too much pressure in the system. I don't see that being your issue though. When the Oxygen sensor was disconnected did you get a check engine light for that? The temperatures that you are getting are normal and your fan should be running at that point and the thermostat should be open as well. I'm wondering if you're getting a vacuum leak when the engine warms up as that wouldn't necessarily cause a check engine light to come on and would cause surging and a rough idle. When your engine warms up and goes into closed loop, try spraying brake cleaner around the throttle body near the intake plenum and at the base of the intake manifold. If the RPMs change or the engine smoothes out or dies then you have found a vacuum leak and need to replace that gasket.
Go Blue is offline   Reply With Quote
Old 07-13-2018, 09:30 AM   #8  
Member
 
Join Date: Sep 2002
Location: Duluth, Ga
Posts: 301
Car: 91 RS
Engine: 305 TPI
Transmission: T5
Axle/Gears: Auburn Pro / 3.42


Re: Pendling idle and with throotle in closed loop

If the AC is in the off position it shouldn't be feeding any adjustment data to the ECM.
91RS5speed is offline   Reply With Quote
Old 07-13-2018, 04:12 PM   #9  
Junior Member
Thread Starter
 
Greengurkan's Avatar
 
Join Date: Jul 2017
Location: Sweden
Posts: 9
Car: 91 Camaro Z28 Convertible
Engine: 5.0 L TPI
Transmission: M39 5-speed manual
Axle/Gears: G80 Limited Slip 3.08

Re: Pendling idle and with throotle in closed loop

I dind't get any a check engine light when I disconnected the o2 sensor.

I even checked with a metal wire on the obd connector but it was only 12 three times.

I havnt' had any overheating problem and I know the fan is working, I flushed the system last summer. I will check fot vaccum leaks, metal expands when it gets warm so that can be something.

I'm also wondering if the ECM is sending can send a bad signal in closed loop to the ICV so that it openes and closes all the time? Can the ICV be bad as well?


The car was running just fine last summer and started after being stored for almost 5 months in a cold garage with a temp of app. 40F. Well, I started the engine up once a month.
Greengurkan is offline   Reply With Quote
Old 07-13-2018, 04:20 PM   #10  
Sponsor
iTrader: (79)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 10,267
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt


Re: Pendling idle and with throotle in closed loop

Usually if a iac is bad it sticks in a position . Resulting in a low or high idle.im really not sure why in closed loop your having a surge. You might try wrapping on the ecm case with a screw driver handle when the engine is warming up and see if the surging occurs.
Tuned Performance is offline   Reply With Quote
Old 07-13-2018, 06:39 PM   #11  
Member
 
Go Blue's Avatar
 
Join Date: Sep 2017
Location: Huntley, IL
Posts: 156
Car: 88 Chevy IROC Z28
Engine: 5.7L TPI
Transmission: 700R4

Re: Pendling idle and with throotle in closed loop

It sounds like the ECM is trying to keep the engine running but something is possibly causing it to lean out which could be his surging??
Go Blue is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Open Loop vs Closed Loop idle 91chevz71 DIY PROM 7 05-14-2007 07:17 PM
48mm throotle body with air foil camarojunkie77 Engine/Drivetrain/Suspension Parts for Sale 0 12-18-2006 02:04 PM
Three issues - Open Loop Acceleration, Closed Loop Surging, Closed Loop Idle Darkshot DIY PROM 8 09-03-2006 08:53 PM
Idle is better in closed loop than open loop -- why? Want to tune open loop now 327_TPI_77_Maro DIY PROM 7 04-24-2005 11:47 AM
Bad idle during open loop and hesitation during closed loop. SgtSkip Tech / General Engine 3 07-31-2002 07:38 AM


Go Back   Third Generation F-Body Message Boards >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 07:08 AM.


All content copyright 1997 - 2018 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: