Can't accelerate - Third Generation F-Body Message Boards


Tech / General Engine Is your car making a strange sound or won't start? Thinking of adding power with a new combination? Need other technical information or engine specific advice? Don't see another board for your problem? Post it here!

Can't accelerate

Reply
 
Thread Tools Search this Thread
Old 09-12-2017, 02:34 PM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Can't accelerate

1991 FIREBIRD 3.1L 6cyl MPFI
The car is stationary, the engine running normally...IF I WANT TO ACCELERATE, as soon as I hardly, scarcely touch the accelerator pedal, the engine stops immediately !!!!!! What can I do ? I put new parts : complete distributor kit, ignition coil, sparkplugs+wires, fuel filter. The fuel pressure is ok. the cylinders pressures are OK. Tech1's error codes are 22-33-35; Data: 0,68 for throttle position; MAP=101 KPA 4.86 V ; Throttle angle = 0%.(firing order is 1-2-3-4-5-6; Cyl#1 is at the front passenger side and #2 opposite front driver side. Wiring #1 on the distributor cap at 8:40pm clockwise.)
Thanks a million for your very appreciated help
jeff50 is offline   Reply With Quote
Old 09-12-2017, 03:09 PM   #2
Junior Member
 
Join Date: May 2015
Posts: 43
Re: Can't accelerate

May need a bit more info before we can help. What prompted you to replace parts? Was it an attempt to correct the stalling or did the stalling start after you replaced them?
rbrackett is offline   Reply With Quote
Old 09-12-2017, 03:35 PM   #3
Moderator
iTrader: (1)
 
Join Date: Mar 2002
Location: Chasing Electrons
Posts: 16,546
Re: Can't accelerate

Code 22 is a TPS Low, that may be a real error. And should be looked into, maybe a bad spot in the TPS where it goes open.

Code 33 is a MAP high and can get set if the engine is struggling to run.

Code 35 is an IAC error, and is caused by the ECM not being able to properly control the idle speed.

Like the MAP high it can be caused by an engine struggling to run.

Back to code 22, a dead spot in the TPS may cause the engine to stop. The ECM sees this as a throttle lift and reduces the injector PW.

At the same time don't rule out shorted Multec injectors. As the injector PW increases the shorted injector coils can prevent the ECM from opening them.

RBob.
RBob is offline   Reply With Quote
Old 09-12-2017, 03:45 PM   #4
Senior Member
 
UltRoadWarrior9's Avatar
 
Join Date: Mar 2014
Location: NC
Posts: 638
Re: Can't accelerate

Quote:
Originally Posted by RBob View Post
....At the same time don't rule out shorted Multec injectors. As the injector PW increases the shorted injector coils can prevent the ECM from opening them.

RBob.
Is there a danger of damaging these old ECM's in a case like this?

It is easy enough to ohm out each injector and see if it's to spec.

Also, +1 on RBob's suggestion to check/replace the IAC and TPS.
UltRoadWarrior9 is offline   Reply With Quote
Old 09-12-2017, 04:14 PM   #5
Member
 
LiveIt!'s Avatar
 
Join Date: Nov 2016
Location: Florida
Posts: 258
Re: Can't accelerate

Second the TPS and fuel injectors should be showing 12 ohms! I'm glad nobody said the car can't accelerate because it's a 3.1
LiveIt! is offline   Reply With Quote
Old 09-13-2017, 05:13 PM   #6
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Re: Can't accelerate

First you must know the beginning: I was on the highway, driving normally, the engine speed was 3000 RPM, suddenly 2000 RPM suddenty 3000, 3 or 4 seconds later 2000, next 1500 after 500 and 0 ! I started the engine many times, it started the two first time only. A pro mechanical says: "it's your fuel pump" . The fuel pressure has been mesured : 40.0, 40.5, 40.7. Then the fuel pressure regulator verified, apparently no problem, but it will be replaced too soon. All these parts have been replaced to eliminate problems from them. The O2 sensor is 9 months old. Apparently the engine was ok, as he turns 15 minutes with the car stationnery. I drived normally 3 Miles but after one stop, the engine runs with difficulties to finally to stop. Now it turns but as soon I touch, just touch ! the accelerator pedal, it stops directly! Actually put new IAC, MAP, TPS and intake manifold gaskets.Thanks for your help.
jeff50 is offline   Reply With Quote
Old 09-13-2017, 05:28 PM   #7
Junior Member
Thread Starter
 
Join Date: Sep 2017
Posts: 3
Re: Can't accelerate

It's the first time I post on this site, I want to reply to each of you to thank you all but my reply appear as a new message. Be sure one thing I'm very grateful to each replyer.
jeff50 is offline   Reply With Quote
Old 09-14-2017, 01:13 AM   #8
Member
 
Join Date: Apr 2016
Location: Perth Western Australia
Posts: 296
Re: Can't accelerate

Quote:
Originally Posted by LiveIt! View Post
Second the TPS and fuel injectors should be showing 12 ohms! I'm glad nobody said the car can't accelerate because it's a 3.1
I was tempted...
zed-028 is offline   Reply With Quote
Old 09-14-2017, 08:09 AM   #9
Moderator
iTrader: (1)
 
Join Date: Mar 2002
Location: Chasing Electrons
Posts: 16,546
Re: Can't accelerate

Quote:
Originally Posted by UltRoadWarrior9 View Post
Is there a danger of damaging these old ECM's in a case like this?
It usually doesn't hurt the ECM. In the case of the 3.1l engine the ECM uses a MOSFET to driver the injectors. Same for the '86 - '92 TPI ECMs.

Quote:
It is easy enough to ohm out each injector and see if it's to spec.
Hard part is getting to the injectors.

RBob.
RBob is offline   Reply With Quote
Old 09-14-2017, 08:10 AM   #10
Moderator
iTrader: (1)
 
Join Date: Mar 2002
Location: Chasing Electrons
Posts: 16,546
Re: Can't accelerate

Quote:
Originally Posted by jeff50 View Post
First you must know the beginning: I was on the highway, driving normally, the engine speed was 3000 RPM, suddenly 2000 RPM suddenty 3000, 3 or 4 seconds later 2000, next 1500 after 500 and 0 ! I started the engine many times, it started the two first time only. A pro mechanical says: "it's your fuel pump" . The fuel pressure has been mesured : 40.0, 40.5, 40.7. Then the fuel pressure regulator verified, apparently no problem, but it will be replaced too soon. All these parts have been replaced to eliminate problems from them. The O2 sensor is 9 months old. Apparently the engine was ok, as he turns 15 minutes with the car stationnery. I drived normally 3 Miles but after one stop, the engine runs with difficulties to finally to stop. Now it turns but as soon I touch, just touch ! the accelerator pedal, it stops directly! Actually put new IAC, MAP, TPS and intake manifold gaskets.Thanks for your help.
Classic example of the injectors failing.

RBob.
RBob is offline   Reply With Quote
Reply


Go Back   Third Generation F-Body Message Boards >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 05:21 AM.


All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: