Tech / General Engine Is your car making a strange sound or won't start? Thinking of adding power with a new combination? Need other technical information or engine specific advice? Don't see another board for your problem? Post it here!

Power Steering Pump Mounting Issue

Old 06-10-2019, 01:55 PM
  #1  
Member
Thread Starter
 
Join Date: Jul 2011
Location: Augusta Township, MI
Posts: 437
Likes: 0
Received 0 Likes on 0 Posts
Car: 1985 IROC-Z
Engine: 383
Transmission: 700R4
Axle/Gears: 3.73
Power Steering Pump Mounting Issue




Hello all,

I went to swap out my water pump today and found that there is a difference between my new one and existing one regarding the hole for the power steering pump bracket.

See the attached pictures. My power steering pump has two lower brackets. The one closest to the block is threaded. The bolt goes through the front bracket, through the pass-through hole on the water pump and then threads into the back bracket.

My new water pump doesn't have a pass-through hole but instead a threaded hole. I'm not sure the best way mount the power steering pump now, or if I even had it right to begin with. Is there a different type of bracket I should be using? Or does this hole need to be drilled out? I certainly don't want to damage a brand new pump.

Mike
Fronzizzle is offline  
Old 06-13-2019, 06:37 AM
  #2  
Senior Member
iTrader: (14)
 
mcgarnicle's Avatar
 
Join Date: Oct 2006
Location: erlangen, Germany
Posts: 823
Likes: 0
Received 0 Likes on 0 Posts
Car: 1991 Z28 1LE
Engine: LS1
Transmission: T56
Axle/Gears: 3.42
Re: Power Steering Pump Mounting Issue

Just get a shorter bolt and bolt it to the water pump, or drill the threads out and use the old bolt.
mcgarnicle is offline  
Old 06-13-2019, 07:30 AM
  #3  
Member
Thread Starter
 
Join Date: Jul 2011
Location: Augusta Township, MI
Posts: 437
Likes: 0
Received 0 Likes on 0 Posts
Car: 1985 IROC-Z
Engine: 383
Transmission: 700R4
Axle/Gears: 3.73
Re: Power Steering Pump Mounting Issue

Because I'm old and can't remember anything for sh*t, I went back and looked at all my purchases from when I built the car. Turns out, I bought a bracket & pulley kit from Summit, and in the instructions, it specifically says "later model water pumps with threaded holes have to be drilled out so the bolt can slide through." So that's what I'm going to do.
Fronzizzle is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Camaro kid97
Engine/Drivetrain/Suspension Wanted
3
09-18-2014 01:18 PM
NCcowboy
Engine Swap
0
08-13-2012 11:47 AM
levelcaraudio
Body
2
04-29-2010 06:16 PM
davep_96
Engine Swap
1
07-02-2008 08:32 PM


Thread Tools
Search this Thread
Quick Reply: Power Steering Pump Mounting Issue


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: