Idle issue after horn off/on - Third Generation F-Body Message Boards

Go Back  Third Generation F-Body Message Boards > Tech Boards > Carburetors
Reload this Page >

Idle issue after horn off/on

Carburetors Carb discussion and questions. Upgrading your Third Gen's carburetor, swapping TBI to carburetor, or TPI to carburetor? Need LG4 or H.O. info? Post it here.

Idle issue after horn off/on

Old 02-04-2019, 05:47 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2004
Posts: 30
Idle issue after horn off/on

So recently i replaced my TPS to address some codes being thrown...which it did. Before doing so, my choke always worked as did the electric kickdowns etc. However, since putting the horn back on im having some problems:

1. Electronic choke doesnt seem to work. Gotta modulate with pedal only. Runs fine when warm. If car is cold and off, and I press gas pedal, the chole flap stays open

2. Choke pull off seems to work...but the green rod going straight up through horn, that is attached via screw, wont let the flap close- even manually. If i take rod off....the flap will close and move regularly

3. The little tab with the "e" on it (think thr problem with thr rod in 2 only goes ro two positions. Straight up and down (pushed to front) and up one step which still has flap open.

My next move is to remove the horn again and double check everything but i hate to do so with new gasket and feel like i am missing something silly.

any ideas ?

Last edited by redvtwin2; 02-04-2019 at 05:51 AM.
redvtwin2 is offline  
Old 02-11-2019, 04:46 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Sep 2004
Posts: 30
Re: Idle issue after horn off/on

Well, after I did some research and actually understood a carb, I was able to get her back to normal. I had inadvertantly adjusted the choke which threw it off. Should have checked that before posting I suppose.
redvtwin2 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
W.E.G.
Tech / General Engine
0
08-20-2017 10:50 AM
crazybird
Electronics
3
12-12-2012 02:29 PM
1Aauto
Sponsored Vendors
0
04-24-2009 10:17 AM
bbsr72
Electronics
7
08-10-2008 06:22 AM
85berlinetta2.8
Electronics
5
06-10-2004 09:35 PM


Thread Tools
Search this Thread
Quick Reply: Idle issue after horn off/on


Advertising
Featured Sponsors
Vendor Directory

Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: