Engine Swap Everything about swapping an engine into your Third Gen.....be it V6, V8, LTX/LSX, crate engine, etc. Pictures, questions, answers, and work logs.

86 TPI 305 into 4th gen camaro no fuel pulse

Old 05-15-2019, 06:05 PM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
86 TPI 305 into 4th gen camaro no fuel pulse

hello!

We are currently taking the engine from an 86 transam sadly it was too rotted out to even bother with but the engine did run. It runs when starter fluid is sprayed straight into the intake and runs well. We arent getting any injector pulse at all. We have the ignition control module harness not plugged into anything and basically what we are trying to figure out and cant seem to find any information on is where this plugs into. We also arent getting any check engine lights. We arent getting any power to the pink/black wire to the ecm either.
zftpi is offline  
Old 05-15-2019, 06:46 PM
  #2  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,733
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

Tuned Performance is offline  
Old 05-15-2019, 06:51 PM
  #3  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,733
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

A6 at the ecm has no power ?
Tuned Performance is offline  
Old 05-15-2019, 06:56 PM
  #4  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

Sorry we do have switched power at A6
zftpi is offline  
Old 05-15-2019, 07:00 PM
  #5  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,733
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

What pink/blk wire are you referring to ?
Tuned Performance is offline  
Old 05-15-2019, 07:02 PM
  #6  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

pink/black is a6 the ignition power to the ecm. in the photo the ignition control module ends in a 12 point harness and we dont know what it plugs into because its not plugged in were not getting power to the icm.
zftpi is offline  
Old 05-15-2019, 07:02 PM
  #7  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

can we wire the icm directly to the computer via hotwire
zftpi is offline  
Old 05-15-2019, 07:11 PM
  #8  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,733
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

Hei coil in cap ?
The icm get power from the switches ignition to the coil
Tuned Performance is offline  
Old 05-15-2019, 07:14 PM
  #9  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,733
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

Tuned Performance is offline  
Old 05-15-2019, 07:15 PM
  #10  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

it fires and runs on starter fluid. the module in the picture is not connected to anything and we cant find what it plugs into. also the colors dont match the schematic you sent. a is blue/white b is orange c is black d is blue/black e is green and those colors matchup to the 12 pin harness on the other side.
zftpi is offline  
Old 05-15-2019, 07:20 PM
  #11  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
Re: 86 TPI 305 into 4th gen camaro no fuel pulse


zftpi is offline  
Old 05-15-2019, 07:31 PM
  #12  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,733
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

Wire the esc as pictured in the schematic post 2
use the letters on the terminals not the wire colors.
The lack of esc will not kill injector pulse or spark.
Miya for knock retard distributor control.
Tuned Performance is offline  
Old 05-17-2019, 01:35 PM
  #13  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 13
Re: 86 TPI 305 into 4th gen camaro no fuel pulse

Identifix points towards the icm/esc being at fault for killing fuel pulse but I don't think we're getting power to the computer. Can't figure out where the computer gets it's ignition power from on the other end. We're not even getting the check engine light on the guage cluster.
zftpi is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
90caddy
TBI
2
08-22-2012 09:29 PM
Ronny
DIY PROM
2
01-14-2011 10:29 AM
draco587
Transmissions and Drivetrain
0
10-30-2008 10:37 PM
89RS_82Z
Electronics
33
08-31-2008 04:28 PM


Thread Tools
Search this Thread
Quick Reply: 86 TPI 305 into 4th gen camaro no fuel pulse


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: