E-rod installed & Passed - Page 3 - Third Generation F-Body Message Boards


LTX and LSX Putting LT1s, LS1s, and their variants into Third Gens is becoming more popular. This board is for those who are doing and have done the swaps so they can discuss all of their technical aspects including repairs, swap info, and performance upgrades.

E-rod installed & Passed

Reply
 
Thread Tools Search this Thread
Old 12-01-2016, 11:46 AM   #101  
Supreme Member
 
Join Date: Apr 2013
Location: North Salt Lake
Posts: 1,353
Car: '86 Camaro, '94 Camaro, 3 others
Engine: LG4 ->L29, L32->LR4, L36, LG4, L31
Transmission: 700R-4, T5WC, 4L80E, SM465, 4L60E
Axle/Gears: 3.42, 3.23, WTB/WTT 2.93

Re: E-rod installed & Passed

http://www.jegs.com/p/Turbonetics/Tu...84347/10002/-1
cali-legal 550 RWHP, but you'll probably need a 4L80E orat least the new4L75E
cosmick is offline   Reply With Quote
Old 12-01-2016, 09:24 PM   #102  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Quote:
Originally Posted by yaj15 View Post
Have any video's of the car driving?
None, sorry.
84 1LE is offline   Reply With Quote
Old 12-23-2016, 03:37 PM   #103  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Small update, just passed first official smog test yesterday.
84 1LE is offline   Reply With Quote
Old 12-23-2016, 06:09 PM   #104  
Senior Member
 
tealman92's Avatar
 
Join Date: Mar 2002
Location: Ontario, California
Posts: 731
Car: 1992 Z28
Engine: 383
Transmission: 700R4


Re: E-rod installed & Passed

Do you have any pictures of how you fitted the exhaust manifolds, cats and the y-pipe back?
tealman92 is offline   Reply With Quote
Old 12-23-2016, 09:53 PM   #105  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Theres some in the previous page.
84 1LE is offline   Reply With Quote
Old 12-23-2016, 11:02 PM   #106  
Senior Member
 
tealman92's Avatar
 
Join Date: Mar 2002
Location: Ontario, California
Posts: 731
Car: 1992 Z28
Engine: 383
Transmission: 700R4


Re: E-rod installed & Passed

Your pic is of the install with your previously stated 98 fbody manifolds and then you said you had to use the supplied erod ones. Did your cat location change when you had to put the erod supplied manifolds in in place of the fbody ones? Just going off your previous posts. Thanks

Last edited by tealman92; 12-23-2016 at 11:03 PM. Reason: Spelling
tealman92 is offline   Reply With Quote
Old 12-23-2016, 11:16 PM   #107  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

No, only the take down pipes needed to be tweaked.The cats have to stay in the same relative location in accordance with the instructions.I think i only updated the pic in the first post, but the cats are essentially in the same spot.Maybe these..


These are definately the later manifolds.Driver.

Pass.Ive got the modified 4th gen pieces still, if anyone wants em.

Last edited by 84 1LE; 12-24-2016 at 12:02 AM.
84 1LE is offline   Reply With Quote
Old 12-24-2016, 02:59 AM   #108  
Senior Member
 
tealman92's Avatar
 
Join Date: Mar 2002
Location: Ontario, California
Posts: 731
Car: 1992 Z28
Engine: 383
Transmission: 700R4


Re: E-rod installed & Passed

Man oh man that is a tight fit. Thanks for posting those great job.
tealman92 is offline   Reply With Quote
Old 12-24-2016, 11:36 AM   #109  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Yep, but still room to squeeze your hand in & most important, no unwanted vibrations.
84 1LE is offline   Reply With Quote
Old 03-09-2017, 02:51 PM   #110  
Moderator
iTrader: (14)
 
five7kid's Avatar
 
Join Date: Mar 2000
Location: Littleton, CO USA
Posts: 43,113
Car: 82 Berlinetta/57 Bel Air
Engine: LS1/LQ4
Transmission: 4L60E/4L80E
Axle/Gears: 12B-3.73/9"-3.89


Re: E-rod installed & Passed

It's been over a year. Any updates?
five7kid is offline   Reply With Quote
Old 03-09-2017, 08:46 PM   #111  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Updates? Not really, just 2k plus trouble free miles.Driving it to work 3-4 times a week.Just enjoying it i guess.
84 1LE is offline   Reply With Quote
Old 03-09-2017, 11:00 PM   #112  
Supreme Member
 
NoEmissions84TA's Avatar
 
Join Date: Feb 2017
Location: Meriden, CT 06450
Posts: 1,651
Car: 84 TA orig. 305 LG4 "H" E4ME
Engine: 334 SBC - stroked 305 M4ME Q-Jet
Transmission: upgraded 700R4 3200 stall
Axle/Gears: 10 bolt 4.10 Auburn Posi

Re: E-rod installed & Passed

Please tell me more about your strut tower brace.
That is exactly what I need. I will be using the dual
snorkel air cleaner on my 334 SBC. But no emissions crap.
NoEmissions84TA is offline   Reply With Quote
Old 03-10-2017, 07:07 PM   #113  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Its just an Edelbrock stb for TPI equipped f-bodies.It wont clear carb set-ups with a steel hood,but will if its fiberglass.
84 1LE is offline   Reply With Quote
Old 03-11-2017, 12:53 AM   #114  
Supreme Member
 
NoEmissions84TA's Avatar
 
Join Date: Feb 2017
Location: Meriden, CT 06450
Posts: 1,651
Car: 84 TA orig. 305 LG4 "H" E4ME
Engine: 334 SBC - stroked 305 M4ME Q-Jet
Transmission: upgraded 700R4 3200 stall
Axle/Gears: 10 bolt 4.10 Auburn Posi

Re: E-rod installed & Passed

Thank you. I will be changing to a Ram Air IV hood.
As long as the STB fits around the air cleaner.
NoEmissions84TA is offline   Reply With Quote
Old 03-17-2017, 10:22 PM   #115  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Depending on how high the manifold/carb are, may still interfere.You can only raise the it about 3/4 inch, brace goes above the air cleaner.
84 1LE is offline   Reply With Quote
Old 03-18-2017, 10:04 PM   #116  
Supreme Member
 
NoEmissions84TA's Avatar
 
Join Date: Feb 2017
Location: Meriden, CT 06450
Posts: 1,651
Car: 84 TA orig. 305 LG4 "H" E4ME
Engine: 334 SBC - stroked 305 M4ME Q-Jet
Transmission: upgraded 700R4 3200 stall
Axle/Gears: 10 bolt 4.10 Auburn Posi

Re: E-rod installed & Passed

That is what I needed to know. Thanks.
NoEmissions84TA is offline   Reply With Quote
Old 04-19-2018, 01:28 AM   #117  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed

Quote:
Originally Posted by 84 1LE View Post
The kit comes w/ a charcoal can, identical to 4th gen f-bodies.There is only a purge solenoid to control vacuum, that's it, pretty old school.I mounted mine under the air filter.

E-rod harness has a redundant MIL wire, which allows you to run a interior MIL.Mine is in the OE location.There is also a MIL in the fusebox.
Is that an actual photo of your car in the signature? It looks BAD ***!!

I have a 78 Trans Am and I'm still stuck on this last bit before sending my car off the CA Smog center: I cannot find a gas tank with a pressure sensor that is smog legal. None of the ones I found anywhere are smog legal that come with the fuel pump in it (which usually have the pressure sensor in it too).

We got a work around for the fuel pump (by using an external one), but what about the pressure sensor? That needs to be connected the the CPU. otherwise that part of the diagnostic will throw an error code and it won't pass.

What did you do?
78TA_In87 is offline   Reply With Quote
Old 04-19-2018, 07:33 PM   #118  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

The e-rod doesn't need a pressure sensor & there is no provision for that on the harness.The evap works like an old school (pre computer days) evap.
84 1LE is offline   Reply With Quote
Old 04-20-2018, 01:24 AM   #119  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

Quote:
Originally Posted by 84 1LE View Post
The e-rod doesn't need a pressure sensor & there is no provision for that on the harness.The evap works like an old school (pre computer days) evap.
Thank you SO SO SO MUCH! You have no idea how many late hours nights I've been researching trying to find answers to this last obstacle on this E-ROD project. And CONGRATS on getting your Camaro Smog Approved!
78TA_In87 is offline   Reply With Quote
Old 04-20-2018, 02:52 AM   #120  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

Quote:
Originally Posted by 84 1LE View Post
The e-rod doesn't need a pressure sensor & there is no provision for that on the harness.The evap works like an old school (pre computer days) evap.
Oh, I'm not sure if I asked the correct question before. I never worked on cars before, but I am trying to ask questions based on what I think my mechanic is stuck on. I may have gotten SENSOR confused with REGULATOR. Did you use a regulator like the one described in the installation manual:


Fuel Pressure Regulator

A nonadjustable fuel pressure regulator with a 60 psi fuel pressure setting is required. You can use Chevy Performance part #19239926 Fuel Filter/ Pressure Regulator (ACDelco #GF822) or other nonadjustable pressure regulator.


found near top right of page 4:
LS3 E-Rod Installation Manual
78TA_In87 is offline   Reply With Quote
Old 04-20-2018, 07:21 PM   #121  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

I used a 4th gen fuel (plastic) tank w/ the sump mounted FPR, so its a returnless system.Some have used the filter/regulator part# you posted.You need a 60 psi system.
84 1LE is offline   Reply With Quote
Old 04-20-2018, 09:46 PM   #122  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

Quote:
Originally Posted by 84 1LE View Post
I used a 4th gen fuel (plastic) tank w/ the sump mounted FPR, so its a returnless system.Some have used the filter/regulator part# you posted.You need a 60 psi system.
Thanks again!

Just 1 last set of questions. I just want to make sure I'm 100% sure. Are you saying that the ECM doesn't do any monitoring of the EVAP system with this E-ROD kit?

The E.O states: "The kit
is equipped with a fully functioning on-board diagnostic (OBD II) system except for the
evaporatlve system checks
. "
Executive Order for LS3

Do I need to configure my car so that the ECM/ODBII is able to check the EVAP system?
78TA_In87 is offline   Reply With Quote
Old 04-20-2018, 10:16 PM   #123  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

The ECM only cycles the purge solenoid once the eng temp reaches 85-95 degrees.As long as the temp is above that threshold the evap is purging.There is no trouble code if you disconnect the solenoid.The ECM only knows a circuit has no voltage reference/feedback.The CEL will illuminate, but only as a warning.

You dont need to configure anything, the kit is basically plug/play.Its your basic closed loop system.The ref will check your evap is set-up properly, but they dont test it.
84 1LE is offline   Reply With Quote
Old 04-21-2018, 06:05 AM   #124  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

AWE-SUHHHHHHHHHM!! Thank you!
78TA_In87 is offline   Reply With Quote
Old 07-10-2018, 12:59 AM   #125  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

I'm almost ready for CA Smog!

I'm just having doubts about the air intake system. My former mechanic installed one that he said has an EO #, but now I know it does not. Summit has a bunch with EO#s but doesn't seem to be any that will fit properly. I re-read your thread and on page 1 it's mentioned you build your own intake? Is that what you had on when it passed or something else? Did they question it at all?
78TA_In87 is offline   Reply With Quote
Old 07-10-2018, 08:51 PM   #126  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

Yes, the one pictured is what i used.You have to follow the instructions in the Erod manual.The TB & filter provided are 4" dia, so the intake has to 4" as well.The straight length has to be 10" minimum from the TB.So the MAF can function properly.There are other parameters that you need to follow.Those are what the ref will check/verify.

You dont need a CAI that has a EO #.It just needs to meet the requirements mentioned in the manual.I dont even think there is a CAI for the erod that is EO approved.Since the kit is basically a universal application.You are going to have to build one to fits your vehicle & meets the requirements stated in the manual.Dont swap the filter either.Used the supplied filter.The ref had no issue with my CAI.
84 1LE is offline   Reply With Quote
Old 07-11-2018, 12:51 AM   #127  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

Below is what I have now. I recall those measurements from the instruction manual and I'm pretty sure my configuration matches it, but I'll verify this weekend at the shop.
I'll need to order the MAF sensor mount that the E-ROD LS3 kit came with. From the pic, looks like it has the one that came with the CAI. My 1st mechanic is missing in action (& out of business) so I need a new mount. Luckily Summit Racing sells the same part number.

Change of subject - I read in another thread you got your car painted somewhat recently. Looks great! Within the next 6 months I'd also like to get mine painted black. I want to ask you about it. I'll PM you about it.
78TA_In87 is offline   Reply With Quote
Old 07-11-2018, 10:05 PM   #128  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

The straight section looks a wee bit short, but that might be the pic.I forget the exact specs for the straight length, but the maf needs a certain amount ahead & behind it.

Ill PM you the info on the body shop.
84 1LE is offline   Reply With Quote
Old 07-12-2018, 01:46 AM   #129  
Junior Member
 
Join Date: Apr 2018
Posts: 8

Re: E-rod installed & Passed

Thanks again!

The long straight section really does look very short from the angle in the photo, doesn't it! I just remembered i took measurements of it last week when I was going to replace it with an EO intake of same size or smaller (this one hardly fit). From the outside bend to the other side where the filter fits, it's 16 1/2". So even if i take away 4" due to the bend, I got 12 1/2". The LS3 instructions say the straight section needs to be a min of 6". I think the MAF is pretty much centered, but will check to make sure it is a min of 10" from the throttle body.
Thanks again!
78TA_In87 is offline   Reply With Quote
Old 07-12-2018, 11:56 PM   #130  
Supreme Member
Thread Starter
iTrader: (7)
 
84 1LE's Avatar
 
Join Date: Nov 2002
Location: Oyth
Posts: 4,487
Car: 84Z-04 triumph
Engine: Erod
Transmission: 4L65e
Axle/Gears: BW, 3.27


Re: E-rod installed & Passed

No problem.
84 1LE is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
[NY] 1989 RS Black 5speed. 6K miles ! Chevy1989 Camaros for Sale 11 05-21-2016 12:09 AM
FS: 1989 Trans Am 49K miles 89TA WS6 Firebirds for Sale 19 03-30-2016 08:01 PM
1990 Camaro 1LE 5 Speed 5L ..204 MILES!! bjpotter History / Originality 88 02-08-2016 11:37 AM
Break calipers jmbjohn316 Brakes 1 01-27-2016 04:27 AM
Not original paint or super low miles, but gorgeous '90 IROC-Z, 'vert. chazman History / Originality 6 12-28-2015 09:55 PM


Go Back   Third Generation F-Body Message Boards > >

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 05:48 AM.


All content copyright 1997 - 2018 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: