TPI Idle too high? - Third Generation F-Body Message Boards


TPI Tuned Port Injection discussion and questions. LB9 and L98 tech, porting, tuning, and bolt-on aftermarket products.
Sponsored by:
Sponsored by:

TPI Idle too high?

Reply
 
Thread Tools Search this Thread
Old 04-16-2012, 08:06 AM   #1  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Location: md
Posts: 74
Car: 88 firebird
Engine: 350tpi
Transmission: 700r4
Axle/Gears: 373


TPI Idle too high?

Just wanted to see if someone could help with a problem I can't seem to fix.
I have an 88 350 that was a 305 tbi and I swaped to TPI. I have been working out most of the bugs but one I can't seem to get. When I drive the car it has a rough idle and also when I come to a stop and put it in park it idles around 1800 and wont go down till it cools down . The car runs ok but does have a slight miss at low rpm's . I have replaced cap,rotor,wires,plugs,maf,tps,iac,coil with new injectors (24lb) and almost all the sensors and checked for vacuum leaks also set the tps and iac and set the fuel press at 50 with the vacuum line unpluged .The car is mosly stock just headers, exhaust, gears and 52mm tb and a prom to match the currunt mods. I am going to make more mods but I would like to start with a good running car first. Any help would be appreciated . thanks

Last edited by lowbird; 04-16-2012 at 08:29 AM.
lowbird is offline   Reply With Quote
Old 04-16-2012, 09:00 AM   #2  
Supreme Member
 
Join Date: Mar 2003
Location: Florida
Posts: 4,761
Car: 1987 Black IROC-Z (original owner)
Engine: 350 Crate with TPI
Transmission: 700R4 with 2400 SLP Stall


Re: TPI Idle too high?

Try resetting the idle with the adjustment screw on the trottle body.
DJP87Z28 is offline   Reply With Quote
Old 04-16-2012, 09:03 AM   #3  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Location: md
Posts: 74
Car: 88 firebird
Engine: 350tpi
Transmission: 700r4
Axle/Gears: 373


Re: TPI Idle too high?

Think that would work? I will try it. The idle is good in gear (700) .
lowbird is offline   Reply With Quote
Old 04-17-2012, 08:53 AM   #4  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Location: md
Posts: 74
Car: 88 firebird
Engine: 350tpi
Transmission: 700r4
Axle/Gears: 373


Re: TPI Idle too high?

I tried that . it did not work, the screw does not even touch the bracket.
lowbird is offline   Reply With Quote
Old 04-18-2012, 12:56 AM   #5  
Junior Member
 
Join Date: Jul 2011
Posts: 15

Re: TPI Idle too high?

How's your timing?
weaselbeak is offline   Reply With Quote
Old 04-22-2012, 10:56 PM   #6  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Location: md
Posts: 74
Car: 88 firebird
Engine: 350tpi
Transmission: 700r4
Axle/Gears: 373


Re: TPI Idle too high?

Timing is at 6 with the wire unplugged.
lowbird is offline   Reply With Quote
Old 04-23-2012, 12:46 AM   #7  
Senior Member
 
Azrael91966669's Avatar
 
Join Date: Nov 2004
Location: cleveland ohio
Posts: 740
Car: 1991 camaro RS
Engine: superram ZZ3
Transmission: 4l60
Axle/Gears: pbr disc 3.27 nine bolt


Re: TPI Idle too high?

are you useing an external tach to make sure its really idleing that high or useing the factory tach

if it was really idleing that high when you pop it in gear it would really be putting a load on the trans

my dads irocs tach is off and shows 1500 when 1st started then shows 800 in gear but really its 900 and 600 cold start and drops to 700 and 550 when warm but i checked with a external tach to see before i when searching for vac leaks and what not
Azrael91966669 is offline   Reply With Quote
Old 04-23-2012, 04:20 AM   #8  
Member
iTrader: (1)
 
jeff_blake's Avatar
 
Join Date: Oct 2009
Location: Mountlake Terrace, Wa
Posts: 405
Car: 86 Iroc + 83 Firebird
Engine: Iroc 305 TPI, Firebird 305 4bbl
Transmission: 700r4 in both.
Axle/Gears: Iroc 3.27 Firebird 3.23

Re: TPI Idle too high?

could be a a faulty tach, one i have is a factory one, its 1k higher at all times. start, scanner reads 800, tach is 1800, ive learned to live with it.
jeff_blake is offline   Reply With Quote
Old 04-23-2012, 04:56 PM   #9  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Location: md
Posts: 74
Car: 88 firebird
Engine: 350tpi
Transmission: 700r4
Axle/Gears: 373


Re: TPI Idle too high?

I checked that already . the engine races high you can tell it's not tach . I am starting to wonder if I was sold a bad iac motor .
lowbird is offline   Reply With Quote
Old 04-24-2012, 01:28 AM   #10  
Member
iTrader: (1)
 
jeff_blake's Avatar
 
Join Date: Oct 2009
Location: Mountlake Terrace, Wa
Posts: 405
Car: 86 Iroc + 83 Firebird
Engine: Iroc 305 TPI, Firebird 305 4bbl
Transmission: 700r4 in both.
Axle/Gears: Iroc 3.27 Firebird 3.23

Re: TPI Idle too high?

u should be able to adjust the iac, least set it to factory and it may help you narrow it down.
jeff_blake is offline   Reply With Quote
Old 07-12-2012, 01:14 PM   #11  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Location: md
Posts: 74
Car: 88 firebird
Engine: 350tpi
Transmission: 700r4
Axle/Gears: 373


Re: TPI Idle too high?

Ok back at this high idle still. replaced iac and still there. Not sure where to go now I have done tps,iac,maf, collant temp sensor,set timming,02, set fuel press and tune up. I have no vaccum leaks . I have reset that iac motor 10 times and it is ok for about ten mins each time than back to a 1500 rpm idle.
lowbird is offline   Reply With Quote
Old 02-24-2013, 09:56 PM   #12  
Junior Member
 
titus78's Avatar
 
Join Date: Feb 2013
Location: placerville, ca
Posts: 8
Car: 1986 iroc
Engine: 305 tpi

Re: TPI Idle too high?

did you ever figure it out?
titus78 is offline   Reply With Quote
Old 02-24-2013, 10:17 PM   #13  
Senior Member
 
Join Date: Jul 2009
Posts: 752
Car: 1991 Z28
Engine: 5.7 TPI
Transmission: 700R4

Re: TPI Idle too high?

Mine is doing the same thing! Hope he comes back with a solution!
micktroup2 is offline   Reply With Quote
Old 05-26-2016, 07:14 PM   #14  
Junior Member
 
Join Date: May 2016
Posts: 3

Re: TPI Idle too high?

Quote:
Originally Posted by micktroup2 View Post
Mine is doing the same thing! Hope he comes back with a solution!
Has anyone come up with the solution to this problem. I have an 86 camaro tpi with the same issue! I've done so much research and it seems like no one has an answer. It's making me irritated as f***.
86IROCZ28NDC is offline   Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1992 camaro 305 v8 TBI idles very high and shifts at high idles db057 TBI 12 03-16-2017 08:20 AM
'92 Camaro RS V6 Engine Spyder_TheGamer Tech / General Engine 1 12-25-2015 05:07 PM
305 TPI wont idle Wade787b TPI 2 09-29-2015 01:15 PM
[QC] 1990 TPI & T5 Engine Harness, PCM & PROM Sanjay Engine/Drivetrain/Suspension Parts for Sale 1 08-12-2015 03:41 PM
Some questions on narrowband vs wideband. IROCThe5.7L DIY PROM 1 08-10-2015 11:24 AM


Go Back   Third Generation F-Body Message Boards >

Tags
305, 85, 88, adjustment, engine, firebird, gear, high, idle, idling, iroc, port, screw, tpi, tuned

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 03:47 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: