Tech / General Engine Is your car making a strange sound or won't start? Thinking of adding power with a new combination? Need other technical information or engine specific advice? Don't see another board for your problem? Post it here!

Relay ????

Old 02-04-2019, 03:50 PM
  #1  
Member
Thread Starter
 
Join Date: Mar 2010
Location: slater sc
Posts: 133
Car: 1989 camaro iroc
Engine: 350 tpi
Transmission: auto
Axle/Gears: 323
Relay ????

Need help identify these relay in pic info in car is 89 Camaro Iroc 350 tpi

Last edited by tcrisp; 02-04-2019 at 04:04 PM. Reason: Info on car
tcrisp is offline  
Old 02-04-2019, 04:06 PM
  #2  
Supreme Member
iTrader: (28)
 
Drew's Avatar
 
Join Date: Jul 1999
Location: Salina, KS
Posts: 17,662
Re: Relay ????

I'm just going to shoot from the hip on this one, so verify before you take it as gospel...

The flat one on the left in back is the ESC module for the knock sensor.

The square one on the left in front of the ESC is for the MAF.

The square one on the right is probably for fog lights.

Of the other two, one should be the fuel pump relay. The other is probably a fan relay.

Really though, your best bet is to get a GM wiring diagram for your make/model of car, and cross check the wire colors with what the manual shows running to each suspected relay. You can guess based on location of where the relay is mounted, but seeing as how it's 2019, who knows what a previous owner may have moved around. Wire colors on the other hand, don't usually lie.
Drew is offline  
Old 02-04-2019, 07:02 PM
  #3  
Junior Member
 
Join Date: Jun 2009
Posts: 13
Car: 88 T.A.
Engine: 305 TPI
Re: Relay ????


Found this before on this site before. Hope it helps
88 TA is offline  
Old 02-04-2019, 07:17 PM
  #4  
Member
Thread Starter
 
Join Date: Mar 2010
Location: slater sc
Posts: 133
Car: 1989 camaro iroc
Engine: 350 tpi
Transmission: auto
Axle/Gears: 323
Re: Relay ????

My or different than the one in that pic
tcrisp is offline  
Old 02-04-2019, 07:44 PM
  #5  
Junior Member
 
Join Date: Jun 2009
Posts: 13
Car: 88 T.A.
Engine: 305 TPI
Re: Relay ????

Originally Posted by tcrisp View Post
My or different than the one in that pic
not sure. Sorry
88 TA is offline  
Old 02-04-2019, 09:09 PM
  #6  
Supreme Member
 
Join Date: Jun 2002
Location: North East GA
Posts: 1,849
Car: 1989 Firebird
Engine: 5.7 LS1
Transmission: T56
Re: Relay ????

The picture is right. In your pic the one unplugged is the orginal fuel pump, the one laying loose is the current fuel pump.
Aviator857 is offline  
Old 02-04-2019, 09:30 PM
  #7  
Sponsor
iTrader: (81)
 
Tuned Performance's Avatar
 
Join Date: Dec 2004
Location: Mile High Country !!!
Posts: 11,618
Car: 1967 Camaro, 91 z28
Engine: Lb9
Transmission: M20
Axle/Gears: J65 pbr on stock posi 10bolt
Re: Relay ????

The wires on the maf burn off sure look frayed.
Tuned Performance is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mkos1980
TPI
0
08-05-2004 09:48 AM
Randy82WS7
Electronics
2
06-09-2003 11:08 AM
Iroc_Z28
Electronics
4
01-28-2002 05:41 AM
JT 85 TA 305
Electronics
1
12-08-2001 06:15 AM
88gta305
Electronics
4
02-01-2001 03:48 PM


Thread Tools
Search this Thread
Quick Reply: Relay ????


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: