Lh0 engine stalls when warm, erratic idle - Third Generation F-Body Message Boards

Go Back  Third Generation F-Body Message Boards > Tech Boards > V6
Reload this Page >

Lh0 engine stalls when warm, erratic idle

V6 Discussion and questions about the base carbureted or MPFI V6's and the rare SFI Turbo V6.

Lh0 engine stalls when warm, erratic idle

Old 11-05-2018, 04:13 PM
  #1  
Junior Member
Thread Starter
 
Firebird2011's Avatar
 
Join Date: May 2016
Location: Rome, Italy
Posts: 73
Car: Pontiac Firebird Formula
Engine: 3.1 LH0
Transmission: 700R4
Axle/Gears: Automatic
Lh0 engine stalls when warm, erratic idle

Ok, Ií m still trying to figure out this problem. Engine stalls when reaches 220F, I have to step the pedal to avoid engine to stall. Runs great when cold. I just measured injectors ohms, all on 12,6- 12,8. Only the FPR is still to be changed. Could be this the solution? Over months I changed distributor, wires, spark plugs, map sensor, EGR valve, TPS, IAC, ECM...
Firebird2011 is offline  
Old 11-05-2018, 04:42 PM
  #2  
Junior Member
 
ChevyK10's Avatar
 
Join Date: Dec 2017
Location: NOVA
Posts: 13
Car: 1976 Chevy K10
Engine: L98 350 TPI
Transmission: TH350
Re: Lh0 engine stalls when warm, erratic idle

We need more information on your vehicle before anyone can help you! Year, engine size, and a list of any modifications are a good start!
.
What makes you think that your fuel pressure regulator is bad? A bad FPR could definitely be your issue, but its best to do some diagnosis before performing repairs on your vehicle. I would recommend to verify that your fuel pressure is within spec.
ChevyK10 is offline  
Old 11-06-2018, 02:04 AM
  #3  
Junior Member
Thread Starter
 
Firebird2011's Avatar
 
Join Date: May 2016
Location: Rome, Italy
Posts: 73
Car: Pontiac Firebird Formula
Engine: 3.1 LH0
Transmission: 700R4
Axle/Gears: Automatic
Re: Lh0 engine stalls when warm, erratic idle

Oops, Ií m sorry! Here it is:

- 3.1 V6 Lh0 120000 miles
- 1990 Firebird
- replaced almost all sensors over the engine bay
- replaced ignition coil
- replaced fuel pump
- fuel pump relay (by the way, I think the car had a non factory anti-theft system, because I found the wires of the three relays on the firewall badly spliced and soldered)

In spite of this, I still have the stall problem. I have to set IAC or TPS? Has this something to do with?

Thank you guys!
Firebird2011 is offline  
Old 11-08-2018, 10:07 PM
  #4  
Senior Member
iTrader: (8)
 
Join Date: Aug 2011
Location: Texas
Posts: 648
Car: 91 Firebird/88 Firebird/91 Formula
Engine: V6 3.1/V8 5.0/V8 5.0
Transmission: 4L60/700R4/4L60
Axle/Gears: 3.23/2.73/2.73
Re: Lh0 engine stalls when warm, erratic idle

Disconnect the vacuum hose from the FPR, start the engine, and wait about a minute and a half. If fuel comes out of the FPR port replace the diaphragm, if not leave it alone.
antares57 is offline  
Old 11-09-2018, 04:23 AM
  #5  
Junior Member
Thread Starter
 
Firebird2011's Avatar
 
Join Date: May 2016
Location: Rome, Italy
Posts: 73
Car: Pontiac Firebird Formula
Engine: 3.1 LH0
Transmission: 700R4
Axle/Gears: Automatic
Re: Lh0 engine stalls when warm, erratic idle

Ok, thank you! Ií ll try as soon as I can!
Firebird2011 is offline  
Old 11-09-2018, 09:05 AM
  #6  
Junior Member
Thread Starter
 
Firebird2011's Avatar
 
Join Date: May 2016
Location: Rome, Italy
Posts: 73
Car: Pontiac Firebird Formula
Engine: 3.1 LH0
Transmission: 700R4
Axle/Gears: Automatic
Re: Lh0 engine stalls when warm, erratic idle

The new FPR is just arrived, bought from Rockauto, the Standard one. I found some o-rings in the box, where do I have to place them?
Firebird2011 is offline  
Old 11-09-2018, 01:13 PM
  #7  
Junior Member
 
ChevyK10's Avatar
 
Join Date: Dec 2017
Location: NOVA
Posts: 13
Car: 1976 Chevy K10
Engine: L98 350 TPI
Transmission: TH350
Re: Lh0 engine stalls when warm, erratic idle

I replaced the FPR on my 350 tpi a few weeks ago, bought the part from NAPA and it came with a bunch of o-rings, didn't need any of them. I haven't had any issues. That being said, if you remove something that has an o-ring, it's good practice to replace it. I think that they include those thinking that you'll be taking apart the fuel rail. Now would be a good time to check/replace your fuel filter. Often times a clogged or old fuel filter is the cause of improper fuel pressure. Best of luck!
ChevyK10 is offline  
Old 12-12-2018, 04:56 PM
  #8  
Junior Member
Thread Starter
 
Firebird2011's Avatar
 
Join Date: May 2016
Location: Rome, Italy
Posts: 73
Car: Pontiac Firebird Formula
Engine: 3.1 LH0
Transmission: 700R4
Axle/Gears: Automatic
Re: Lh0 engine stalls when warm, erratic idle

Thank you ChevyK10! I replaced the FPR, now the engine runs much better, but occasionally stalls when I turn the wheel full left or right and when Reverse is engaged. Maybe a defective TCC solenoid?
Firebird2011 is offline  
Old 12-12-2018, 05:54 PM
  #9  
Moderator
iTrader: (1)
 
Join Date: Mar 2002
Location: Chasing Electrons
Posts: 17,220
Car: check
Engine: check
Transmission: check
Re: Lh0 engine stalls when warm, erratic idle

If you have disconnected the battery will need to do an idle learn. This is required on the 3.1l cars with an automatic. A search using my name as the author and a keyword should bring up a thread or two on it.

It also helps to clean the throttle body butterfly. The EGR really gunks it up.

RBob.
RBob is offline  
Old 01-03-2019, 01:57 AM
  #10  
Junior Member
Thread Starter
 
Firebird2011's Avatar
 
Join Date: May 2016
Location: Rome, Italy
Posts: 73
Car: Pontiac Firebird Formula
Engine: 3.1 LH0
Transmission: 700R4
Axle/Gears: Automatic
Re: Lh0 engine stalls when warm, erratic idle

Hi guys, happy 2019!

Just to let you know the car doesnít stall anymore when in Drive, thank you all for the suggestions! Iíve however noticed that, when in Overdrive, the engine stumbles and tries to stall like I never did the relearn procedure. How can I solve this?
Firebird2011 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Pupkin
Tech / General Engine
2
04-22-2018 11:28 AM
Pupkin
DFI and ECM
11
09-16-2017 06:44 AM
robertfrank
TPI
5
02-09-2013 01:38 PM
balistic
TPI
5
01-07-2010 06:20 PM
garone91rs
Tech / General Engine
15
03-30-2003 09:01 PM


Thread Tools
Search this Thread
Quick Reply: Lh0 engine stalls when warm, erratic idle


Advertising
Featured Sponsors
Vendor Directory

Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: