Search



Go Back   Third Generation F-Body Message Boards > Tech Boards > V6
Register Forgot Password?

V6 Discussion and questions about the base carbureted or MPFI V6's and the rare SFI Turbo V6.

Welcome to ThirdGen.org!
Welcome to ThirdGen.org.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join the ThirdGen.org community today!


Reply
 
Thread Tools Search this Thread
Old 04-18-2012, 07:47 PM   #1
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
2.8 V6 Problems

Hi I have a mpfi 2.8 V6. It runs terrible though. RPMs go from 1k to 500 at idle, sometimes it even stalls out(usually when i come to a stop sign). It will randomly drop 1k rpms for about half a second while im driving and car feels like im stomping on the breaks. Also when im driving and I'm semi heavy on the gass it starts cutting out at around 3000 RPMS but if I floor it it will sometimes power through it without cutting out, but it will drop into a lower gear at way higher rpms. I have brought it to several shops, but it only has an error code every once in a while and they tell me they won't be able to tell unless it comes up with a code. Any suggestions would be appreciated, thanks.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-18-2012, 07:48 PM   #2
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

I also forgot to mention that when the weather is hot, all of these problems intensify.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-18-2012, 08:29 PM   #3
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

If you have a tach, watch it as you're launching. If it drops down to near 0, your ignition module is basically telling you it's time to replace it. Most ignition problems intensify with heat. Most shops haven't had to deal with pretty much being stranded by a dead module. (actually, my car was in the shop "being diagnosed" for the above until the module finally kicked the bucket and they were still scratching their heads... I replaced the module in 10 minutes and drove it out)
__________________
Dan V.
1988 Chevrolet Camaro IROC-Z28 (bought as a body shell) Hardtop, 1991 VIN T engine, MegaSquirted hybrid 3100 V6 swap, est 225 HP, 235 TQ. 85 NWC T-5 manual transmission, GU6 3.42 open rear axle with aluminum drums. Founders' LCAs and Track Bar. Polyurethane suspension bushings, Wonderbar, Moog 5358 front springs. Dash taken from a 1993 Camaro, console from a 2002.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-18-2012, 08:37 PM   #4
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

It sometimes drops to about 100 then will surge up past 1000. I will look into the advice that you gave me. Thanks
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-18-2012, 10:26 PM   #5
Supreme Member
 
evilemokid94's Avatar
 
Join Date: Aug 2009
Location: Elwood, IN
Posts: 3,650
Car: 1986 camaro Sports Coupe
Engine: L31 350
Transmission: 89 700R4
Axle/Gears: 3.42 gov lock

Classifieds Rating: (6)
Send a message via MSN to evilemokid94 Send a message via Yahoo to evilemokid94
Re: 2.8 V6 Problems

What are some other sympotums? Reason I ask is becUse of my cars sitting still, in drive or park the rpms surge, like the rpms will drop then come back up and my car dies after iv driven it for a second till I restart it( turning most times) and right after I start it, it drives really sluggish till it warms up alittle.
__________________

1986 camaro sports coupe with a base firebird spoiler, iroc hood, Z28 5 spoke rims, 20% window tint.
-------------------------------
5.7 L31 motor, carter all preformance 600 CFM carb, hei distributer, edelbrock proformer vortec intake, 95 LT1 camshaft, alex springs, double roller chain, rebuilt 700R4, 2.5 inch exhaust with flowmasters 80 series muffler.
evilemokid94 is offline vBGarage Page   Reply With Quote
Old 04-19-2012, 05:58 PM   #6
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

It does serge like that, but its more random. I might be able to drive it one day fine. Then reandomly ill drive it and it will be terrible.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-21-2012, 03:39 PM   #7
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

Does anyone think that the cutting out might be a vss sensor? Whats happening is at 3000 rpms in certain gears it seems like it wants to shift but it doesnt really, it just kind of stops.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-21-2012, 03:46 PM   #8
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

VSS has NOTHING to do with the trans shifting except for the torque converter clutch above 45 MPH. It's not electronically shifted (1993). If it's not shifting right, you have trans issues as well, or the TV valve cable needs to be readjusted (the green cable on the throttle body).
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-22-2012, 02:10 PM   #9
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

Ok thanks. Just found out car is showing code 30 and 34. (Low voltage at manifold absolute pressure sensor OR Fuel injector OR Park or neutral switch OR CAM, Low voltage (high vacuum) at mass air flow sensor (or MAP sensor)). Could this be the casue of my problems and how would I go about troubleshooting it?
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-22-2012, 05:56 PM   #10
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

Double check your codes... No such animal as a code 30.

Take one of the relays by the brake booster and swap out the one behind the passenger's side headlight with it. Disconnect the battery for a moment and reconnect it. Start the engine and check to see if code 34 pops back up. No MAP sensor on a V6 before 1990 and after 1984.
__________________
Dan V.
1988 Chevrolet Camaro IROC-Z28 (bought as a body shell) Hardtop, 1991 VIN T engine, MegaSquirted hybrid 3100 V6 swap, est 225 HP, 235 TQ. 85 NWC T-5 manual transmission, GU6 3.42 open rear axle with aluminum drums. Founders' LCAs and Track Bar. Polyurethane suspension bushings, Wonderbar, Moog 5358 front springs. Dash taken from a 1993 Camaro, console from a 2002.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-23-2012, 05:55 PM   #11
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

Yeah my bad was 33 and 34 wrote it down wrong, thank you. Does this mean that I need a new maf sensor? I unplugged the maf sensor and it idled good. Then pugged it back in and it did what it was doing before.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-23-2012, 07:12 PM   #12
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

Did you swap the relays yet? More than likely, with a code 33, your MAF has taken a dump. However, you need to make sure there is power to it to get rid of the code 34.
__________________
Dan V.
1988 Chevrolet Camaro IROC-Z28 (bought as a body shell) Hardtop, 1991 VIN T engine, MegaSquirted hybrid 3100 V6 swap, est 225 HP, 235 TQ. 85 NWC T-5 manual transmission, GU6 3.42 open rear axle with aluminum drums. Founders' LCAs and Track Bar. Polyurethane suspension bushings, Wonderbar, Moog 5358 front springs. Dash taken from a 1993 Camaro, console from a 2002.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-23-2012, 07:17 PM   #13
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

No i havn't, I spaced it :O. I will try that now, thanks .
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-23-2012, 07:19 PM   #14
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

When you're done swapping relays, check to make sure you have 12V on the orange wire at the MAF connector, otherwise the code 34 will come back to bite you :P .
__________________
Dan V.
1988 Chevrolet Camaro IROC-Z28 (bought as a body shell) Hardtop, 1991 VIN T engine, MegaSquirted hybrid 3100 V6 swap, est 225 HP, 235 TQ. 85 NWC T-5 manual transmission, GU6 3.42 open rear axle with aluminum drums. Founders' LCAs and Track Bar. Polyurethane suspension bushings, Wonderbar, Moog 5358 front springs. Dash taken from a 1993 Camaro, console from a 2002.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-23-2012, 07:27 PM   #15
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

I am having trouble finding the relays that you are talking about. What do they look like?
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-23-2012, 07:51 PM   #16
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

They're the 3 black boxes bolted to a bracket to the right of the brake booster (may be only 2 if you don't have A/C) with wires plugging into the bottom.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 12:47 PM   #17
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

Found it(hiding behind intake) thank you very much. Bought new relay put it in and the 34 went away. It does run like 10 times better now, but does this mean I need a new MAF sensor? I went and checked at a local parts store and they were $300 bucks new or $80 to referbish the one I have now.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 01:39 PM   #18
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

Quote:
Originally Posted by Pensfan11 View Post
Found it(hiding behind intake) thank you very much. Bought new relay put it in and the 34 went away. It does run like 10 times better now, but does this mean I need a new MAF sensor? I went and checked at a local parts store and they were $300 bucks new or $80 to referbish the one I have now.
I will say this much: STAY AWAY FROM THE REMAN MAF SENSOR. I went through 2 of them in 2 years because the Chinese that remade them didn't make them right.

Let the car run for a while as it is and then post back if the code 33 comes back. Replace the MAF relay that you swapped (the one mounted behind the headlight, not the one from by the booster as that's obviously good).

If the code 33 comes back, you probably need another MAF. If you have a Camaro, I might have a good one (I haven't exactly looked at it yet to determine anything other than it's a V6 sensor). Other than that, you may get lucky on eBay, but, again, STAY AWAY FROM THE REMAN MAF SENSORS.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 01:42 PM   #19
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

I ran it for a while and the 33 is back, but I have a firebird . Do you think it is a good idea to buy one used one off of ebay?
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 02:36 PM   #20
Supreme Member
 
Maverick H1L's Avatar
 
Join Date: Aug 2003
Location: LeRoy, NY
Posts: 7,086
Car: 1988 IROC-Z28 with a V6
Engine: 3.1L V6 LH0/3100 L82 Hybrid
Transmission: Borg-Warner NWC T-5
Axle/Gears: 2HL/GU6 3.42 open

Classifieds Rating: (8)

Send a message via AIM to Maverick H1L Send a message via Yahoo to Maverick H1L
Re: 2.8 V6 Problems

Quote:
Originally Posted by Pensfan11 View Post
I ran it for a while and the 33 is back, but I have a firebird . Do you think it is a good idea to buy one used one off of ebay?
If you're lucky, you MAY find a NEW GM on eBay for cheap... I got mine there for the Bird back in 2010 for $50, new in box. I don't know if she has any more, though (dealer parts buyout from closing dealer, I suppose). You're taking your chances with used, but anything's better than the one you have now, I guess.

Before you go and buy one, take it out and look in the engine side at the film in the middle of the board. It should be clean and flat. If it's dirty, clean it. If it's wavy, the MAF is toast.
Maverick H1L is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 03:27 PM   #21
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

Just cleaned MAF and it was very clean when i put it back it no problems on the inside or out still came up with 33. Found sensor on amazon for about $60. Thanks alot for your help, I know it must be kind of annoying helping someone like me. I've taken my car to several different shops and they just ignore what I ask them to look at and find other problems that they can take my money with.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 04:48 PM   #22
Supreme Member
 
project89's Avatar
 
Join Date: Apr 2008
Location: Utah
Posts: 8,398
Car: 89 RS 89 iroc 87 firebird
Engine: 3.1 Turbo/ 355 twin turbo
Transmission: a4 w/ 4500 stall/ a4 / t5
Axle/Gears: strange s60 /w 3:42's

Classifieds Rating: (1)
Re: 2.8 V6 Problems

check ur local jy for a v6 camaro or firebird and grab the maf off that, should only cost u 10 bucks
__________________
Car 1 1989 Iroc-z 353SBC 200cc HEADS 224/224 CAM HSR TWIN GT3582 TURBOS 1,000+HP OR BUST AKA THE DAILY DRIVER
Car2 1989 RS 3.1L v6, KB pistons, delta cam,ported heads/intake, custom stainless turbo headers, garrett 60-1 turbo 380+HP@9PSI
Car3 1988 Firebird. stock bottom end, ported heads, delta cam, custom intake, gm 4-71 roots blower HP???? TBD


project89 is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 09:54 PM   #23
Junior Member
 
Join Date: Feb 2012
Posts: 27

Classifieds Rating: (0)
Re: 2.8 V6 Problems

I live in a very small town. Its slim pickins.
Pensfan11 is offline vBGarage Page   Reply With Quote
Old 04-24-2012, 09:54 PM
ThirdGen
1992 Camaro




Paid Advertisement


Reply

Go Back   Third Generation F-Body Message Boards > Tech Boards > V6

Tags
28, 34, 86, 87, 88, 89, camaro, code, dies, heats, high, idle, mpfi, problem, s10, skip, v6
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 


1982 Camaro '82 || 1983 Camaro '83 || 1984 Camaro '84 || 1985 Camaro '85 || 1986 Camaro '86 || 1987 Camaro '87 || 1988 Camaro '88 || 1989 Camaro '89 || 1990 Camaro '90 || 1991 Camaro '91 || 1992 Camaro '92


All times are GMT -5. The time now is 02:14 PM.


Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.5.2
All content copyright 1997 - 2014 ThirdGen.org. All rights reserved. No part of this website may be reproduced without the expressed, documented, and written consent of ThirdGen.org's Administrators.

Emails & Contact Details